3 red lights vesc, new board

getting a triple red light on initial startup of vesc, had rc control then it vanished so I walked home… i flashed the fw on vesc to 2.54, but still getting a triple red light on initial start, rc control is completely missing, i checked ppm settings but dont know which one will fix whats going on, motor detection test also fails, but before that it was smooth sailing… now I have to unstrip a motor mount screw, either way I have no power, and when it was working, the motor was spazzing untill wide open throttle…


3 red blinks is normal at startup on the vesc. what controller are you using? any fault codes beside failed motor detection?

no fault codes, no matter how I run the test. generic controller/w reciever say diy_v2c. originally i think it was supposed to be configured for ppm, I lost rc input randomly, so i looked but couldnt find burnt electronics… motor is really weird though, slow speed doesnt work and clicks and behaves intermittently, while high speed works if i push start… Board will stay on and vesc has been flashed ok, however no imput… and motor calibration fail in bldc…

I would have guessed that something wrong with that controller. But I can’t figure why motor detection is failing. did you try motor detection with the remotes receiver disconnected from the vesc? Maybe a signal from the receiver is messing with the motor detection.

pretty sure the reciever was off, the arrow keys work in the application, so I know the boards got drive power, as I move em the motor spins up, strange, so the diy reciever has 2 options for input leads, one is cn4 and the other is blank… either way Ive tried both and couldnt get control back, maybe I should flash again, and leave the tx/rx stuff unplugged… the little reciever has a tiny reset button, I will try that in the am, as far as radio transmitting goes do you know how to do the rf initial setup?

You should unplug the receiver from the vesc and try the motor detection again. I don’t think you need to flash the vesc firmware. I don’t know what the pairing procedure is for that remote, it should have come with instructions for pairing. It’s beginning to look like the remote is causing all the problems though.

hall sensor detection failed finally showed up, adjusting the current, it kinda spins, but it sounds very sick… =/ having the receiver removed was good advice the detection now works, and the motor spins, it just struggles to get going a bit and there are a string of numbers -1, -1, -1. so on and so forth for the description

Try disconnecting the sensors and change Bldc settings to sensorless. And do the motor detection again and see how that works. There could be a problem with the sensor or sensor wires

not exactly sure which sensors i need to dc, would this pic help? I think the board is good now, i just need to get tx up, I would just connect my stuff from another setup but i dont feel like riding with a dx7s around my neck =| Im pretty sure the motor i got now doesnt have a sensor… maybe im wrong…

I meant disc the motor Hal sensor. If your motor has a Hal sensor, there will be a harness of small wires coming out of the motor with a plug on the end that plugs into a socket on the Vesc. If your motor don’t have it then just check bldc settings and make sure it’s set for non sensored motor.

ya just realized its b/c i dont have that sensor lol, ya i double checked the options it is set to sensorless, It runs good now that the reciever is unplugged, when I plug it in though none of the ppm settings are working unfortunately, and i have no clue how to pair it,

Here is a nice big picture of the diy reciever. I tried finding some information on pairing it, but nothings come up yet.

ya no dice, on any combination of powering esc, holding handtrasmitter power down and with or w/o small white button on rx module down before powering vesc or after powering vesc…

Maybe time to try a different remote

if you have any suggestions that can have me rolling in less than 24hours let me know lol!!

would this be ok you think?

Thats a nano remote and they are known to have issues just like the one you already have.

Where are you located?

california, not many hobby places close by, i went ahead and ordered one it looks identical to the torque boards, one from the diystore… not very happy to hear about this remote issues though,