(copied from my post on vedder.se forums)

Hi guys,

I managed to get everything working (homemade vesc), the board was moving with the remote (nothing on it), but when I put my foot on it and applied a small pressure, I found some lag in (that’s what I thought) the command transmission. And then nothing, even with my foot off. The red led was blinking and the board not moving anymore.

I connected it back to the computer and I had a ABS_OVER_CURRENT (-136amps something like that). I rebooted the VESC, seemed to be ok (no error showing up and correct current values), but now the motor doesn’t move anymore :frowning:

It’s like the VESC “see” it moving (the pikes is when I hit the gaz but the motor doesn’t move):

My motor conf:

When I run a motor detection it doesn’t move the motor and I get bad detection but no error in the real time data. So close to ride it… :cry:

Is it bad doctor ?

Some news : I saw that there were a possibility that the phases could be shorted, so I disassembled the motor but everything looked fine.

I tried again and now I can get the motor moving a little bit. It just clicks and raises immediately an ABS_OVER_CURRENT.

I checked my shunt they seem fine (added some tin to be sure). Also today (I don’t remember changing anything) the real time data look like crap:

My DRV is brand new, the motor worked few minutes perfectly (but with no load). I guess the problem came when it started to draw more amps.

Don’t know where to look, I’m desperate… :disappointed:

Post some high res photos and we can take a look to see if something is out of order and can be cleaned up or resoldered.

Do you have some picture? Maybe it the Ground plane of the DRV that is not correctly solder.

Make sure you didn’t short out the shunts on themselves, or check if the shunts sense are well soldered

I checked the shunt and added more tin, don’t know how it could come from it. I’ll check the shunt line to the drv.

And the DRV pad is good, I made sure to solder it correctly (it’s my second DRV, I blew the first one either because I soldered a diode the way around or because the pad wasn’t correctly connected).

Here are the pics:

Could it come from the big caps ? I’m not sure the soldering is perfect (I’ll fix it tomorrow).

Thanks a lot for your help :relaxed:

Other thing you can do is check the continuity of the drain-source of the fet to see if you have one that is blown. Same thing for gate-drain, must be high impedance.

@Blasto : I checked the shunt and they seem to be “shorted on themselves” as you said. I think my multimeter is no accurate enough and see it as a continuous line (here in red). Is it normal or should it see a resistance between the red dots ?

I don’t know what you mean by the drain-source and gate-drain. Could you please be more specific ?

Thanks :slight_smile:

Thats normal, accros the shunt there’s 5mOhm of resistance, you won’t be able to measure that with any multimeter. What i mean when i say short themselves, is the small leg is short with the big leg. But i dont think this is the case.

Ok, but what about drain-source and gate-drain ?

Need to look in my old threads, i explained this already w some fancy ms paint pictures. Hold on

Do you have the title of the topic ? I looked to your old posts but didn’t find your piece of art :confused:

I had this issue when I had bad connections from the FETs to the Motor. It was evident when I inspected the plugs and they had burn marks from the arcing electricity. Perhaps ensure that you have a solid connection that can pass high amperage/voltage through?

Are these pins soldered together?

Yes, these are normal

Well, I checked my soldering and didn’t see any burnt marks :confused: And yes, the two pins are connected together

Maybe those will help you for checking the mosfet (Like @Blasto suggest)

1 Like

You should get the same respond from the multimeter as testing a regular diode

I tested as you showed. Here are the results: -in position 1 (picture 1) I have 0.431v value -in position 2 (picture 2) I have 0.572v value

If I put the probes in the opposte way, I do have OL but not instantly, it “slowly” raise up until it displays OL.

However, in resistor mode, I can read the same value in both position (reversing the probes) :confused: Not good right ? Values: -in position 1: 41kOhms for the for the two fets of the right, 5MOhms for the third one (the one tested on the picture). -in position 2: 38kOhms for all fets.

Those values are the same for the fets on the other side of the PCB.

these value seem ok, the most important is you don’t have any short.