Abs over current from dead stop

I’m getting this error more often now, it only happens if I accelerate from a dead stop at 20% of throttle, VESC reboots itself and I don’t have any control from the remote. If I accelerate very smoothly it accelerated with no error.

Can I fix this issue by upgrading the C18 and C26?

1 Like

I’ve had this and it was a simple adjustment of settings to fix… What voltage and your setup info?

What is your configuration and settings specifically? Screenshots of the BLDC tool will help.


Motor max: 80A Battery max: 40A Motor min: - 60A Battery min: - 10A

Start up boost: 0.020

Cutoff start: 30V Cutoff end: 28V

Runing 10S4P on dual belt with VESC

And what is your absolute max and your drive mode? FOC or BLDC?

Absolute max: 130A

I’m runing BLDC

post screenshots with your other settings, there might be something else. Nothing wrong with the things you posted. Also did you check your wiring? Might be a small short somewhere.

I believe I am also having this issue with my vesc. Does your vesc occasionally do this when trying to brake? And you loose your brakes for a second?

@kptheinventor - this is what i experienced on my test bench. After sharing my configuration settings, i adjusted the voltages slightly and the abs overcurrent error was resolved. It was something simple like adjusting the voltage up a few volts to not error. When it errored it would lose communication for a second or two and give me 3 red blinks (iirc). After adjustment - no more problem.

Not like the OP who has this when starting from a dead stop - that’s different and more concerning…

I can never get my back to do this error when it’s plugged into my computer. It only happens when I’m physically out riding it. Do you know what settings you adjusted?

Well I’m still having the issue, so no setting has been useful yet. Hope someone could give me some suggestions

Have you checked your battery? A bad weld could mean spikes in current maybe.

Otherwise its a bad vesc

I have an exact same setup on a different board but the issue does not happen there, the only difference is on the issue-board I have a 15/36T on 97mm wheels and on the non-issue-board 16/40T on 100mm wheels.

I uploaded the latest @ackmaniac firmware v2.54 yesterday, I’ll test it today and report back.

Thanks for the suggestion, I’ll take a look at the battery today

I think you were correct, my battery is sagging too much, even on the bench with no load.

I’ll take off the enclosure tomorrow

Are you still having this problem?

Hey man! yes, I’m still having the issue, but it only happens when I press the throttle on a hill from a dead stop or on launches very harsh terrains

Did the voltage sag have any effect on anything?

I don’t think this has anything to do with voltage sag at all. In fact my sag was perfectly normal, my capacity tester has a very high sample rate so that’s why I incorrecrlyt though I was having sag

Ah alright

I’d suggest to use hybrid mode, just a JST connector and solder it to the sensor wires on the motors, you won’t have this issue as manu times as today and a much smoother launch from a dead stop.

It’s only 3 bucks