After VESC Firmware update, motors not detected?

I havent seen that before, are you running 12s? And check to see if youve blown the mosfet

Hmm bad sensors??

Yes 12S, how do I check to see if I’ve blown a mosfet?

Id say the easiest way is to look at the actual thing closely and see lol

Check for burn marks and stuff

yea just check and see if any of the FET’s look burned at all, post a pic here when you get a chance too

All of the FETS look perfect.

Thanks for helping me out btw, I really appreciate it.

Hmm look really really closely at the pins like reeaaaaly closely, and tb vesc?

If theres nothing wrong then I think the temp sensors are bad, try reflashing your vesc to ackmaniac’s

1 Like

The mosfets are looking perfect… I actually rode the board for about 15 miles perfectly before updating the firm.

Sorry I am not to familiar with the term “flashing” or ackmaniacs fw. How do I flash my vesc to ackmaniacs?

flashing = updating

  1. Click on this @Ackmaniac
  2. Under his most popular topics, find the one that says something about extended BLDC tool (should be one of the first ones)
  3. Scroll to the bottom of his first post in the thread and download the files.
  4. Unzip the files, install the program
  5. Read his directions in that thread on how to flash FW
1 Like

Okay I’ll try this and tell you how it works. Thanks

1 Like

Here check out this link

1 Like

I followed all the steps, installed the FW, and everything. But I still get

The following faults were registered since start:

Fault : FAULT_CODE_OVER_TEMP_FET Current : -0.3 Current filtered : 0.1 Voltage : 45.15 Duty : 0.001 RPM : 6.7 Tacho : 3 Cycles running : 0 TIM duty : 3 TIM val samp : 1050 TIM current samp : 3150 TIM top : 4200 Comm step : 2 Temperature : 377.04

So I guess it must be the temp sensors… I wish I could turn the temp settings off. Unless you have any other suggestions I think we figured out my problem. I did buy these ESC’s off a friend who got them repaired.

Thanks guys

I thought you should do motor detection with fully charged battery? As I can see the voltage is 45.15 not ~50.4V?

Overtemp fault indicates to me that you uploaded the incorrect firmware. You may have fried the PCB if you tried running a motor test.

Is that typical? Wrong fw blows temp resistor?

No but it will cause an incorrect temp measurement.

1 Like

It was the correct firmware from the start. I made sure of it. Plus, the motor was never detected so nothing could’ve been fried.

Did you ever figure this out? I tried @Ackmaniac’s latest 3.1 firmware with a Torqueboards VESC, and I got the same “Over Temp” error, and could not even get the motors to spin during detection. I switched back to the 2.54 fw and BLDC tool from his original thread and everything works fine now.

I guess you are installing the wrong firmware for your hardware. If you have the 4.12 hardware you have to choose this file.

It also could be because of wrong readings from the motor temp sensor. But you can check that when you have a look at the realtime data.


Ah, yes. Derp. That makes sense. I’ll try it again with the proper hardware selected this time. I’m still kind of a VESC noob, and was trying your latest software way too late last night, er, this morning and missed that. I figured it had to be something simple that I was missing since it worked on your old fw.

Thanks for the prompt response and all your hard work on this project. Really great stuff, especially with the app. I’ll definitely be sending a donation your way soon. :+1: