All new 2019 VESC-Tool release

HW4.12 is set up in BLDC after FOC detection

:smiley: Ok, thats basically a very good thing since there are many 4.12 based ESCs out there that don’t work well in FOC but a better description would have been great. The new (nice) App denies to work properly with old FW most of the time so communication about major changes might need to improve :slight_smile:

yeah but how does that help those of us that want to setup FOC on V4.12 hardware?

edit, also does data logging work now? it wasnt working in the last version

It doesn’t prevent setting up FOC, it just defaults to BLDC to prevent damage to those who don’t work properly in FOC :wink:

which is basically preventing you from setting up in FOC is it not? I choose FOC and it gives me BLDC. Not really what one would expect.

Also Frank, When setting up the firmware update for the hardware it was supposed to update over CAN, which it did, but then when I went to do detection it told me that both VESC’s had to be on the same version firmware? I connected to the slave directly, checked the firmware which indicated it had been updated but I decided to do another firmware update regardles. Then I plugged back into the master and detection worked.

Sometimes it takes another try when that message appears, I guess its some hickup in CAN communication. I had these a lot at the beginning of the 3.5 line but the latest versions seemed to have improved that. The best thing would be a popup window telling that “Detection was successful, however, since you run 4.12 hardware you were defaulted to BLDC. If you are sure that your hardware is able to do FOC feel free to switch it, the proper settings were made already”


yes I agree that would be much better, doing it without a prompt is a bit silly imo

1 Like

Sometimes it gives this message. Simply start the wizard again.

The Motor Wizard is quite simple now and minimises questions noobs can’t answer. It’s pretty much an autopilot. Standard is FOC nowadays, but HW4.12 can get damaged if quality is low and if you use funny settings or non ideal motors. So you have to FOC it manually.


yes I understand that and let me just say, the new tool is SOOOOOOOOOOOOOOO much simpler than the old one. auto connect, firmware update, motor config wizard, input wizard. Boom, done. I like it, good for noobs as you say. It does however set outrageous current settings, which is not noob friendly! 99A/ -99A on a 10S battery is not good

So does the RT logging work now? I could not get it to work in the last version.

Also the mobile tool shows a lot of potential, I like what I see here, with telemetry logging and some tidying up (and that ability to have miles instead of kilometers) and its going to be amazing.

1 Like

Battery Amps are not so important. For regen you have an Amp limiter built into your thumb and for drain the motor amps are the limiting factor.
Motor power and battery capabilities should match anyway. Sort of useless to strap a 6380 to a 10S2P pack.

Frank - puts into BLDC to be safe

Also Frank - Battery Amps are not so important



:grin: Exactly my thoughts :smiley: I really appreciate what Ben did when he designed the VESC and is still doing with the Firmware and the Tools BUT I think everything is getting more and more trampa-centered, just like trampa is a puppetmaster or, as I previously was joking, Lord Vetinari. @trampa You might use overpowered Lipos in your Boards but most of us don’t and battery max and min are quite important for us. I for myself know what I’m doing but the new Tool makes it easier for noobs to make bad mistakes. They might even be happy about the wrong settings at first since you get more power, but eg. someone uses dual motors that are capable of 40A according the new detection and has a battery that can do 30A max leads to things go badly wrong. You should care too since you try so hard to bind the VESC™ to trampa™.


Looking to switch my AT tires to 97mm urethane wheels. Do I still have to go into motor setup and adjust for wheel size?

Hey man. How are your Focboxes running with the new vesc software? I’m running ackamaniac on dual flipsky 6374s for. My

And it is running ok. My remote was acting a little funny so I’m thinking of reflashing But I’m also thinking of putting the latest vesc firmware on there.

Fine. I have done all the fw upgrades with no problems. Metr now works with the new fw. If you want to reach me go to forum. since I don’t frequent here any more.

hey guys maybe this isnt the right place, but how do i get my vescs (hw 6, ESCapes) to connect via can? i thought the vesc too had an option to select slave or master vesc in the ppm setup wizard but the new vesc tool i downloaded isnt opting me to do that (even older videos that use vesc tool have the pop up, mine doesnt get it)

Connection tab, activate CAN FWD.

Is it usual to get an “unknown hall error: 255”?

Really nice. Downloaded VESC tool mobile app and connected to my board - Dual Focboxes 4.12 - via Bluetooth. Everything worked fine. Running the newest Firmware now and the app shows everything to me. Also changing profiles now and seeing realtime data is everything I need and did before with metr app.

I really like the info about the driven kilometers of the current trip.

Does anybody know if the VESC (Focboxes or whatever) saves the kilometer (mileage) overall? From the beginning since turned on the first time? I would like to have an odometer about my km/miles altogether, since riding. … I always liked it in the Boosted or Onewheel app (never had one of these boards), so it would be nice to know how “old” my board is.

If the info is somewhere in the VESC then it should be easy to read it out. Thanks. And keep up the good work, Benjamin.

It is if you don’t have hall sensors.