Almost no brakes in FOC. 12s3p 30Q battery - Flipsky 6.6 - Meepo HubMotors Style

Hi guys! So basically I upgraded my battery from a 10s3p to 12s3p on my short board. I then changed from Maytech vesc to flipsky 6.6, Bestech D140 charge only BMS. I would first out with Diyeboard, meepo…hub motors. I used them in the past at 1-s with Maytech’s vesc and I like them. Only concern was the speed, being actually 65Kv gives great torque but low speed. On both the vesc I am using @Ackmaniac’s firmware, connect via CAN BUS. On the new Flipsky 6.6 I first tried BLDC sensorless but the motors really struggle to start even on bench testing, while was fine at 10s before. So I decide to move to FOC sensorless. Weird thing that I noticed, the motors spin in one direction during motor detection, and then they run in the opposite one on street. Is it normal for FOC detection? I repeated the detection like 20 times always the same. No reverse motor configuration enable in the VESC TOOL. Except for that, which doesn’t happen in BLDC, FOC is really deadly silent. I have a weird behaviour when I engage gently the brakes on bench test Basically they keep spinning really at low speed until I brake stronger (mainly the motor connect to the slave vesc). Then I thought maybe it’s only on bench test and I tried out on street…The accellaration is really smooth ecc…FOC does remove like 2-3 kmh, but the overall experience is better, bad news they do not brake! Really I was use to a really strong and reliable braking force with these motors at 10s and now that I move to 12s and new vesc they suck. I had to foot brake all the time, that would be expensive if I need to change one shoe every month :laughing:

Setting are basically the same as before: image
image image I was aalso thinking that maybe now 57V is too low since the battery is 50V fully charged but it doens’t make any sense because it barely brakes at low speed too.

Do you guy have any idea way it sucks like that? am I missing something?

Thx thx

PS: @sayekim Hi man, I know you used meepo hubs at 12s, maybe you see the problem. Thx!

strange that it´s different behavior with the same settings. I would set the bat min a bit more low like -10, but i think this shouldn´t be the issue. did you make sure that your remote is calibrated right? which mode you use, current no reverse with brakes?

I tried with two different remotes, Firefly adn Nano-x. Both well used in the past without problem. I can lower the battery min but with dual vesc at -6A before I could really brakes strong. To me is more vesc related. Even a slightly better brake force would be still too low. They really do not brake. Yes I am usign current no reverse with brakes. Watt limited with Ackmaniac firmware. Maybe it doesn’t work well with VESC 6 hardware

did you tried it with the stock firmware?

I think it is the esc too. Settings look fine and brakes were great on focboxes with 12s.

Try the maytech with 12s if you haven’t already.

1 Like

No didn’t try it because I like the possibility of switching the modes by the app. But since doesn’t work I can give it a try.

I am afraid the Meytech will fry instantly at 12s :laughing: I think that a lot of people are using those ESC now. I hoep that I didn’t get the only two faulty ones.

it just would be one option i would consider. it´s not a big deal to flash the firmare back and forth.

Oh yeah forgot about that there.

But wasn’t that only for foc? Bldc was good for 12s on maytech.

Get escapes or focboxes already and go belt drive. You will not believe how crazy 6374’s are.

1 Like

The motor detection spinning one way but running spinning another thing on the flipsky vescs is a known issue. It’s a bit strange but just flip your wires and keep it in mind. Weak and a bit weird braking behavior on the flipsky seems to also be a thing. Maybe it has to do with their components choice…


Well really they almost don’t brake it’s impossible to use them like that. If that is the case they are totally trash. How can I ride without brakes.

1 Like

Yeh I know I now got 6384 motors for my next project. Crazy big. Belt drive is not my thing I really don’t like the sound and the style too.

1 Like

I will try. If that is the braking force I get you can basicaly throw the in the garbage. Better that you test them to because if that is the case we should all together ask Flipsky to fix them or refund us because it’s impossible to use it. I don’t understand how many people said that they are good.

1 Like

I don’t mind the sound. Besides in foc they aren’t that loud. I only went hub because I thought to stay stealthy to avoid authorities. Now riding full gear and going to many group rides that point is kind of mute now.

1 Like

if i would have a case and the time i would through them on and test them. without brakes they definitly useless! did you check your fault log? maybe something cut off your break force.

I will check the error but at really low speed I don’t see how that can be the case. I hope the original firmware will help but also @sofu specified that they have less braking force. She is testing the dual 6.6. I really don’t understand why all the people that used the single 6.6 don’t say that. I didn’t read anything about it.

1 Like

You can use duct tape for a test. Just saying because the more we wait the less pressure we can put on them. These are expensive garbage if that is the case :laughing:

In Belgium Esk8 is ok. I just don’t like the bulky rear truck with belts ecc… I know that you get the best performance out of it. I will think about in case, but so far hub motors satisfied my needs.

1 Like

Out of curiosity, what’re your settings at? So far I’ve tested them on raptor 2 hubs and direct drives and results have been a bit mixed… I’ve yet to test them on a belt drive though so I can’t say for sure if it is actually the vesc…

I posted them in the first post