Antispark switch won’t let current through

Recently, my anti spark switch from Mboards (Version 1) has stopped working. I worked with my 10s5p battery 3s2p battery and now without any changes has stopped working, I know it’s not any of the connections because I have checked those but it still doesn’t work. Any ideas why it doesn’t work and if there’s any ways to fix it?

Don’t use it. It sounds fucked. Unless you get one of the one potentially fully functional and reliable anti spark switch for $$, just wire in a loop key and don’t deal with antispark switches being a pain. Mine worked for a good 10 months before :poop: ing out, still not worth it.

1 Like

Do a keyloop. Way more reliable. Here How to

Just removed one from a board LHB made after a couple of weeks. I don’t like them either. Use a loop key or a BMS with eswitch built in

You were unlucky. All my luna/mboards failed in the on position so no need to remove just rely on loop key. Moral. most antisparks suck big hairy balls.