Starting Tips | Ask Questions | Introductions | Categories

Badwolf + GT2B Problem (SOLD)

Hey guys, I received this BadWolf and GT2B mod along with some other used parts on this site, and it appears the original owner may have not done this mod correctly, as I am unable to get this baby to work. Upon power on and binding, the transmitter will connect to the ESC/Motor, however I will have no control. The motor will just spin uncontrollably. While I’ll admit it’s pretty fun to ride this thing full throttle, it’s not fun at all when the only way to stop/slow down is to turn the transmitter off, which in turn stops the motor. I’m selling the two along with the receiver to anyone who may be able to fix it for $40. If you don’t get it to work, hey, you got yourself a perfectly functional BadWolf Case! Also willing to trade for a working plain GT2B

@JT_Clemente have you tried adjusting the throttle trim inside the case? This just sounds like the trim needs to be adjusted. It’s worth a try before giving up on it.

Yeah, I’ve tried all of the knobs, it seems that the middle one is the only one that affects performance in any way. By turning it left and right, it’s the only form of control I have, as it slows the motor ever so slightly. I’ve had no luck with any other knob or switch configurations.

My throttle connects in the OTHER white socket.

Have you… uhm… tried that?

throttle is in wrong channel.
You have connect it in socket near trim pots.

that explains your problem :slight_smile: let us know if it worked

@thisrealhuman @NerijusM @barajabali no luck, plugging in there solves the problem of the motor spinning uncontrollably, however I get no response from the trigger. When I have time later, I may try re-binding it to see if that has any effect.

1 Like

@JT_Clemente @thisrealhuman my trigger is also connected to the rightmost port. I think that the leftmost is for the steering wheel so the input might have different limits. @JT_Clemente I bet this will fix your issue once you re-bind and adjust the trim.

Thanks for the input guys! I’ll let you know how it works out!

1 Like

Is your ESC plugged into channel 2 on the receiver?

Yes it is, haven’t had any luck

I had to install the resistors on channel 1’s pins.

I’ve been tinkering with this bad boy, but still no luck. Can anybody think of anything else that it could be? I’m lost as to any solutions. As of now, its up for grabs @ $40 for anyone that wants to take a shot.

Better off just selling the case