Batteries are not charging

Ok , so i bought imax b6 mini (original one) with some crap 18v 2a psu for 4$. It worked the first time, without the batteries plugged in. It was the only time it worked. I didn’t get any response from imax support team, so i decided to buy isdt q6 pro with 24v 16,7a and 400w psu. Charger it self works, but it doesn’t detect my batteries. The thing is, i was stupid and let my batteries discharged and they got a little puffed. It ain’t puffed much, but still. Photos are down below. 60490234_351600855487256_9071936476454846464_n 60770796_470425663697492_8831853319346454528_n

In the picture, it looks like you’ve got your balance lead plugged into the wrong spot. Move it all the way down, so the black wire is lined up with the mark on top of the charger’s case.

I mean, it looks like this. There is basically no other way of plugging it so i doubt i could mess something60587297_607045723141203_9060481072826941440_n up here

1 Like

Alright, looks fine from that angle. Have you checked your individual cell voltages with a multimeter?

i don’t have one, it’s my first build, and first contact with electronics. I’m quite young :slight_smile:

You should not be building electric vehicles without access to a multimeter. Go buy one. It doesn’t have to be a $300 Fluke, but you should absolutely have a multimeter when you’re working with batteries and electronics that can deliver hundreds of amps if you’re not careful.

Can your charger can at least show the cell voltage ? I think they went under voltage, there is a way of bumping them up again using Nimh I think (not sure), then go back at normal lipo charging mode once the voltage is high enough

1 Like

Hm, nothing from the photos seems to be your issue. Have you turned it off and on again :wink:

but seriously, maybe wiggle the connectors a little? A multimeter would be great help for sure,

I have tried to wiggle the connection, didn’t work. I am just going to borrow/buy some kind of multimeter

1 Like

Shucks. Yeah try to borrow one at the very least. I hope you can resolve this easily

1 Like

Sometimes it can, but not always, if it does it shows something like “battery cell voltage 1.0v” but it doesn’t show the voltage for individual cell

Very weird, it would be surprising that the battery voltage is at 1 volt, even for an over discharge battery, that’s very unlikely Really go get a multimeter, it’s very useful, and it’s only 15 bucks or something, go check amazon or your local store !

Maaaan it turned out to be the right thing. I bumped it to around about 3.2v and then used li-po charging mode to charge it to 4.2v. Thanks everyone! I was getting very frustrated that i’m going to need to buy new batteries. Hope to ride my board tomorrow for the first time!

1 Like

Glad I could help ! But don’t do that with your batteries, they are severely damaged by that : you will have less range with those, sometime a lot less

I know but it was the only way. Anyway, thanks for help!