Battery problem, VESC, problem or both?

Having some issues with my setup. (At the moment I’m running TB Single 6374, 12s4p, and 4.12 VESC. The set up worked fine for months until I installed Bluetooth module from BKB. Then about a week ago I was riding and the board Powered down and gave me a FAULT ABS OVER CURRENT followed by a FAULT ABS UNDER CURRENT reading. This happens several times in a row on my way home from a ride. When I got back home I wanted to plug into my computer and see what was going on. When I tried to power the board back on the bench it would not turn on… I hooked it up to the charger and it came on reading 85% when I disconnect it however it wouldn’t turn on again until connected to the charger. I unplugged everything And tried to check all the connections which all seemed good. Then when I plugged the VSC back into the battery it’s sparked and blew fried my XT90 connector. I could barely get them apart but when I did I noticed it was burnt up. I then Soldered on a new male and female XT90 antispark connector to the VESC and battery and tried to plug them in and again my battery won’t turn on… I disconnected them and Plug the battery into the charger it came on…unplug the charger and the battery will flip on and off. However when it’s plugged in to the VESC nothing… I’m lost here. Not sure what I should do to Test whether it’s My VESC or my battery causing the issue. Any advice Is greatly appreciated.

Do you use a bms for discharge? Do you use a loopkey? The abs over and under current faults you had the one day sound like there was a loopkey not fully plugged in, or a bad connection between your battery and vesc. Could be that this already damaged something on your vesc and that than resulted in the spark and melting down of your xt connectors. If you get your vesc powered on, does there blink any red light?

The TB battery has a built in BMS and on off switch and I just plugged it directly into the VESC via the XT90 antispark that it came with. Do I need a loopkey as well? Im trying to figure out another power source to check it. I have some 3S LiPo Packs but they use XT60 can I just make an adapter from the XT90 to XT60 and plug it into that?

I would try to use the Lipo, just to check if the Vesc is OK… You could use and adapter…if it powers and shows no problems (red light blink or so), then you know what to do…

If I remember right there is a discharge bms in the tb battery. A loopkey is never bad, but if you have a discharge bms with e-switch you don’t need a loopkey. Could be that there is an issue with your bms, or the switch on the bms or all together. To check the vesc with your lipos is a good idea. Sure you can make a xt60 to xt90 adapter, that shouldn’t be an issue

So tried plugging the VESC Into the LIPO battery and it shorted out the anti-spark XT 60 Loopkey. TheVESC never turned on obviously. Does this mean the VESC is shot? Looking at it visually it seems normal but I’m not sure exactly what to look for…

That could possibly be crossed wires somewhere

Where would it be a crossed wire in the VSC or the BMS somewhere?

Take one of your 3s lipos and plug it straight to the vesc. Nothing else. Probably pop a small bit but nothing to worry about as youre only doing it once or twice. What your looking for is if the vesc will power on by its self. If the lights come on then you know your vesc is ok.

Next you add in the bms. Pull the jst as you’re only wanting to see if the bms is operational. Wire in the bms to the lipo and vesc. If the vesc lights up, you know the bms is good.

Process of elimination. If after everything works with the lipo, I’m willing to bet its in the battery.

Ok. The 3s lipo has an XT60 and and the VESC has an XT90. I made an adapter. Should I use that or just attach a Xt90 to the lipo or Vice versa. Whenever I plug it in it’s not a little spark it’s enough to weld the two plugs together I have some pictures of the connectors after plugging them in and also the adapter I made… thanks for the help I appreciate it. image|666x500 image image

Well that’s bad. I’ve done that once, it happened after one of my vesc’s went to a dead short and I melted my loop key.

Show us your vesc, the battery, and the adapter all in one picture (disconnected obviously)

image image image image image image image image image image

1 Like

So I also added some photos of the Vesc. I took off all of the shrink wrap to get a better look and everything seems ok but I’m pretty new to all of this. Thanks

1 Like

Anyone see anything wrong with the VESC?

Hey ive got a question. Ive got this board with a dual esc off of ebay, and 2 3s batteries with a belt driven motors all bought off ebay. It worked awesome for quite some time. I plugged it in to charge it and then i went to ride it again, it wouldnt do anything. The brakes would work, but it wouldnt accelerate. I found that if i push started it, it would go but it was glitching a lot. Like the esc was bad. I replaced the esc with the same model, and it didnt do anything. I replaced the motors thinking it would solve my problem. Still nothing. The only origiinal part is the battery. Do you have any idea whats happening?Screenshot_2018-11-06-06-19-16 Screenshot_2018-11-06-06-19-21

1 Like

Check all your connections. Pay close attention to phase wire connections @ esc, motor and where the two connect between each other. Report back after.