Battery voltage and max input setting

Using space pro4 10s battery. Did exactly the same setup as Jacob said in his video which was max input at 42 V when my battery was around 75% juice, ran perfectly. Then charging the battery to full but it started cutting itself off.

Connecting to BLDC tool everything seemed fine, didn’t break any chip or ic stuff down which was a big relief. Found out the realtime data keept saying OVER VOLTAGE when I was using the remote to run the motor and motor detection failed and said “bad detection results and overvoltage error”.

Well the question is can I just put 43v instead of 42v on max voltage input? Already tried put different amps on motor or battery but didn’t make a difference. Only put 43V on max input would make everything running smoothly. Just wondering has anyone encountered this scenario and why would some people put 42V and nothing happened on their 10s board?

Yes you can, I don’t know what batteries are in the space cell but standard LiPo are charged at 4,2V per cell so 42V. However if using 43V helps you putting 43V wont hurt your VESC. But you may check your charger because it seems like you’re overcharging your pack.

1 Like

Uh the bldc tool showed around 97% juice the voltage was like 41.4V then I used remote to crank it. Sometimes too much throttle it ran to 42v (just a instant, strange) then cut off. But when I run 42v for max voltage for motor detection it didn’t cut off I thought its because didn’t use full throttle.

I think I didn’t overcharge the battery, as soon as I saw the charger showed green light then I disconnected them…but the fact was before that the battery itself already showed 100%. :nerd:

When riding, there will be some voltage sag caused by load which prevents over voltage fault when max is set at 42v When bench testing, the absence of load reduces that voltage sag. Try setting max at 42.5 and if it still shuts down, set it at 43v. I don’t think setting the max voltage 1 volt high is gonna cause any problem.

It’s normal for the battery to show 100% before the charger’s green light comes on. Keep charging until the green light comes on. And you don’t have to unplug the charger as soon as the green light comes on. The BMS will not allow the battery to over charge. And the if charger’s output is 42v, it can’t charge the battery higher than 42v.

Leave the max voltage setting at 57v. Its purpose is to save the electronics from overvoltage. Setting it at 42v puts yourself in danger of losing brakes. In what video did Jacob recommend this?


Chaka is correct !,

I have a 10s battery also and my Max Vol is set at 43V But …when you Begin to ride on a fully charged 42v battery then you use BRAKES you Generate Voltage and this bring it over my 43V Max setting and cutts Off !!

I have yet not changed the setting to 57 V but i will to avoid this problem again . This will happen in only the first few min of riding if braking ,untill Batt V drops a little.

1 Like

I had the same problem with the space cell and set the limit to 42.6V


Okay so just wanna make sure that I can put 57v on my 10s pro4? Wow that’s impressive didn’t even think of that. I thought only 12s would use 57v setup…

Even for 6s ?

I would just leave battery max alone at 57v, there’s no reason you should have to change it.

1 Like

The bms will protect the pack and the “shut off” should allow for brief peaks in voltage where the vesc is more sensitive.

1 Like

The advice in that video tutorial to limit the max input voltage like this is completely wrong. And it is causing a lot of over voltage issues people are having with their VESC.

1 Like

Well I was one of those guys lol

perhaps some explanation by @jacobbloy why he did it that way in the video ?

this is only done after you know your battery pack. the vesc will have voltage spikes when braking and this could be well over 10v for a very short 2-5ms. i know my pack doesn’t charge over 41v so setting it to 42v has no problem me on most situations, the voltage spike happens when the motor stops spinning very quickly the motor in a geared system will slow down a lot slower with weight on the board and this generally means that more current less voltage.

the vesc is a very temperamental peace of hardware when you do not understand all aspects of the operation and the problem is even if i explained every thing i knew about it in my videos i would still miss things as i don’t know every thing. also many would not understand or watch the whole video.

you don’t have to set your voltage cut of settings at all if you have a good bms


it also seems that the some vesc could have a voltage tolerance issue, get a good voltage meter test your battery voltage then test it on the vesc real time data you might find its a couple of V out

1 Like

Thanks Jacob.

The max input voltage value has nothing to do with the pack charging and setting that value below 57V is not helping there at all. @chaka mentioned this already in his above contribution as well. It creates unnecessary over_voltage_error messages all the time and the forums are full of it.

On a side note: the same applies to the general Enertion VESCs presets “multiple ESC over CAN” which creates some additional issues (I am not indicating that this was you, but again, it’s unnecessary).

I wasn’t saying it has any thing to do with charging, I was saying that my battery doesn’t charge past 41v and I don’t have any over voltage problems while setting it to 42v. But setting it to 42v stops my vesc from pushing 45v into a 42v battery pack when braking. But as I said if you have a BMS then there no need to worry about this.

As for multiple ESC over can, this is needed for running 2x vesc over can. What courses problems with the keys not working on your keyboard is having can Fardwarding enabled. But this is also required if you want to program 2x vesc from 1 USB port so in a application like the raptor it is good. But the same conflict can be caused by having 2x applications enabled at once like being in current mode in both ppm and UART and having UART and PPM set at the same time. But for my self I just quickly set my vesc to no application when wanting to debug and such with BLDC TOOL and my keyboard keys.

1 Like