Benchwheel pairing issues

I got one from there & 1 from MEB, they both charge the same. The one with my kids Benchwheel Dual 1800 does too. So freekin weird.

Here’s me trying to pair this thing! I wait for 7 seconds but nothing, although when I release the white button, the flashing light stays solid blue, indicating to me that it’s paired, but then the remote keeps flashing…

Try powering up the board 1st. The connect the RX, hole the white button n the RX and power on the remote (while keeping the remote power button depressed, do not release) all within a second or so of each other. I think I remember someone having that issue and powering on the ESC before hand, for a few seconds let it be fully running, seemed to solve the issue.


Still nothing. :frowning:

I’ve contacted them, one of them must be dud. I saw a video on YT where a guy pairs it to his actual BW board, he gets the first beep (on), then the two beeps that I get and then a third which actually looks like it’s signifying the pairing. I don’t get that third beep!

I actually don’t get the 3rd beep either, just 2. But the RX is solid and the remote is solid, so I know its good. Honestly, I don’t think I’ve ever spent more than 60 seconds pairing one of these remotes. I’m thinking your RX and remote are mismatched or something.

Yeah tell me about it, this is ridiculous!! :frowning:

Hopefully I’ll get some joy with Benchwheel

Benchwheel have responded. They’ve seen my video, they agree it’s a product fault and are arranging for a replacement…

Let’s see if this happens!

Great, good luck.

1 Like

Turns out they sent me their scooter remote! Not the DIY one.

They’re sending me a replacement remote FOC.

Hopefully it won’t take forever to arrive…

That’s crazy, glad you got it worked out.

1 Like

I finally received my replacement remote from Benchwheel a few days ago, pleased to say that it’s now paired and working, just need to get me a new ESC now with decent brakes… Would love a VESC but they’re so expensive :frowning:

What do you do about throttle trim for the Benchwheel remote?

1 Like

That’s good to hear, that was sorted out faster than I thought. I haven’t tried any esc other than vesc but I can say that the vesc does a very good job and is worth the investment. It gives you such a smooth ride. Although I can’t personally compare it to any other esc since I haven’t tried any other.

I have never needed it, which is good as its not available on a benchwheel remote :slight_smile:. If you get a VESC you can tweak the PPM setting in the BLDC tool.

1 Like

Cheers! I hope I won’t need it then…

Just ordered a second hand VESC off of a member on here, can’t wait to get back on my board, especially now the summer is coming!! :slight_smile:

1 Like

I can dig that, I’ve been without one on occasions and it sucks :slight_smile:. You can really tweak any remote to being really responsive or slow in th VESC PPM tab, I usually keep mine pretty tight with very little dead range, but I’m really used to the benchwheel remote.


Nice! Looking forward to a really custom setup…

1 Like

Hey guys. What’s the behaviour like on your Benchwheel remotes? I have both the Winning V1 (which for me has been excellent with no problems!) and recently gotten my hands on the Benchwheel for my 2nd build.

I was wondering about yours, because if I compare the two, firstly the Benchwheel seems to have a much bigger dead-zone than the winning, regardless of my settings in the VESC (even down to 0.01MS). A good few millimetres travel from centre on the Benchwheel don’t show up as changing the pulse-width in the VESC so I’m assuming thats some kind of slop in the potentiometer.

Secondly, and more annoyingly, the pairing is much worse in my experience. Not the initial pairing as that worked fine once I figured out the correct procedure, but the pairing when you power on the board and the remote. Now, the Winning V1 has been awesome on my first build (and the same if I bring it across to my second build) and super fast and non-fussy (?) when turning on. Doesn’t matter which you turn on first or at what time, once they are both on they are connected within a second or two. The Benchwheel on the other hand is super unreliable, sometimes connecting, sometimes not, usually I have to have the board on first before turning on the remote, in which case it sometimes find the remote, and sometimes doesn’t, even if i cycle the remote on or off after the board has been turned on, it just won’t find it. Do you think I have a dodgy remote/receiver? Or is this normal behaviour with having to make sure the board is on and then the remote (Quite inconvenient in day to day usage, especially if I’m not even sure if the remote has connected as when the receiver is in the enclosure I can’t exactly check the see if the LEDs are blinking on the Rx!)

Sorry for the wall of text, I’ve become quite obsessed with getting my second build perfect and wanted the benchwheel remote to be a part of that! :stuck_out_tongue:

@mmaner @darkkevind @Norco

I have noticed a larger dead zone in Benchwheel remotes, as compared to the GT2B and Nano-X, but not significantly so. If you are using the @Ackmaniac firmware you can use the PPM wizard to negate the dead zone, at least I have been able to.

As far as binding is concerned, there are a couple of different version of the Benchwheel remote, some use a button on the RX and some don’t.

Sounds like you might have a suspect unit. Mine has been pretty flawless to be honest. When I first set it up i had some brief sticking of the throttle at max which was weird but once it was properly set up in BLDC then its been spot on since. I have to say I have been impressed and glad I dont have the bulk of the GT2b or hassle of modding it.

Hey, do you think that this is/was a reciever problem or remote itself?