BLDC Tool not recognising my VESC - "No Firmware Read Response"

Hey, I’ve come to configure my VESC for some fine tuning but am having a problem… Here is what I have done: I first turn on the board and wait for the light to stop blinking on the VESC. Next I open the BLDC tool and then plug in the VESC. On the Drop down menu for COM(s) Only COM1 shows up. I click connect. For a breif moment, it says connected then comes up with “No Firmware Read Response” and then says not-connected. I downloaded and installed COMs drivers ( and tried again. Nada.

(I’m using Enertion’s VESC-X) Any suggestions/help? I have literally no idea…


try another usb cable. micro usb’s often are for charging only.

Alright I will tomorrow, good point never even crossed my mind! :joy:

and check the comms port you’re using

What do you mean? It only comes up with the one option - COM1

Unplug the usb, plug into a different usb port. Should make an audible sound. Sounds like the lead

Yeah, I have. No sounds, I’ve tried 5 leads now and none of them are working. I mainly only use Micro USB for charging things, dont own an android etc so I never had the need for a data cable…

5 is a bit coincidental. Rebooted pc? What power source are you using for vesc? Might be lower than the low voltage cut off limit

Two fully charged 5s lipos in series so 10S. Ill reboot my pc and check though

Try one battery.

I got it, it was the cable(s) :joy: I ended up using a micro usb cable from my amazon echo which worked xD Alls good. Thanks though

1 Like