Blew up my Unity

Took my board out for a ride after some successful in-garage tests, and about 30 meters into my ride the board stopped responding, and as I picked it up got a bit of smoke and sizzle coming out of my unity. I took it inside and there’s a part in front of the battery-connector-side hall sensor plug that’s got a hole burned in it. The DRV chip on the same side also has some blisters suggesting that it’s toast as well. Powering up the unit caused more smoke to come out of the first part.

![IMG_3502|375x500](upload://dYw

VrXiBNxhGiGROkH8yCUQKKdt.jpeg)

Now this is likely 100% my fault, but I’d like to know which of my mistakes to avoid to not burn through any more of these controllers. In no particular order:

  • Took the thing apart, i.e. removed the silicone cover but also the heatsinks. I’m pretty sure everything went back together correctly.
  • Scratched a little hole in the conformal coating from the shunts to try and diagnose what turned out to be a software problem (reinstalling firmware fixed it).
  • Installed VESC 5.3 beta firmware on the thing (ran through the full setup and everything seemed normal, with the possible exception that the default switching frequency was 25kHz and I left it there).
  • Possibly engaged the handbrake feature at 10A while moving at a brisk walking pace (this feature should be disabled over 0.1 m/s but my math might be off).
  • Set a battery current limit that might have made the batteries’ internal protection circuit kick in

Any insight into what the fried part does? This is totally my fault, right?

2 Likes

Bad antispark? You wanna get rid of your fried unity?

The DRV chip blowing out like that indicates that one of your MOSFETs failed (most likely). This chip drives the FETs (which drive your motors)

If you have a failed MOSFET it would be likely due to the Motor current being too high for this little FOCer to handle, or a Voltage spike that exceeds the Maximum, either of those could cause a FET to fail which can cause the DRV to melt, and you will likely measure a short-circuit between the Motor connections (with motor is disconnected)

Possible you had a short in the motor cables or some physical problem with the installation (i.e. Voltage Spike on E-Brake). But this only really equates to a failed MOSFET causing the Driver to Blow, so if the MOSFETs look good, it’s possible the fault was more obscure.

One concern you mentioned in the configuration after your firmware uploading that could have strained this device in an unintended way. Too high switching frequency will heat the DRV chip more, I don’t know what’s normal, so not sure if 25kHz is high enough to be a catastrophic difference, switching MOSFETs too fast will create excessive heat.

1 Like

The resistances are definitely off on the one side of the controller. 115 ohms between the two outer phase leads.

The motor currents were set a good deal lower than the rated capability, so I don’t think it was over current on the motor side.

Would a battery over current protection kicking in potentially cause a voltage spike?

How much throttle were you giving it? Are you using the discharge, on BMS? What battery?

There was a long discussion about switching frequency a few years ago. It seems as though people were pushing the default 20kHz up to 25-30kHz, and getting significant noise reduction, obviously getting very excited, and then finding that it causes lots of wasted energy in the VESC.

Doing this massively increasing the energy required to switch the MOSFETS (which is the job of the DRV chip). That Awful blue line below shows a Flipksy 6.6 @25kHz (vs ~20 in yellow/orange), we can see a 5% system drop, all that energy is likely in the MOSFET switching, so the VESC will get much hotter and waste more energy by switching faster.

Source: https://vesc-project.com/node/658

Since your MOSFETs are not reading 0 Ohm, It’s likely they are okay. The fault could have been overheating in the DRV, and once failed burning out the inductor supplying it. Replacing the two failed components may bring that device back to life, but it’s a gamble that other components haven’t fried in the melt-down, and you would need a re-work station and to know how to use it, if you want to make that repair. Where are you based, and do you know anyone that can solder SMT components?

The FOCBOX shouldn’t have fried this easily, if you opened it and found improperly fitted heat-pads around the failed components, then that is a worthy discussion for the manufacturer. But also keep in mind that this likely worked when it was shipped to you, and through firmware updating you may have set something out of range causing the issue.

My advice for next time is ride it before you update the firmware, obviously need to do the Motor/Battery setup, but that is all. My friend also did an update for a Flipsky6.6 and lost so much default configuration, it took a long time and several FW versions to get it spinning again.

1 Like

I found a “before” photo of the Unity and the part that’s especially fried is a TVS diode. This makes me think that the precipitating event was a voltage spike, maybe related to setting the battery charge current rate too high, causing them to shut down.

I blew up some very expensive equipment at work once with a voltage spike, generating electricity on a motor connected to a car engine, the load bank had faulted so the energy had no-where for it to go, the voltage will increase until it finds a way through, this one went in a 3ft spark out the back of the PSU.

Basically when you brake (slowing/stopping) you are running the motor as a generator, and the voltage goes up as energy is created and starts rushing toward the batteries.

The voltage level is only held at normal levels by the ability for the battery to absorb the energy. Batteries (and cables) have internal resistance, if that resistance is too high, or the batteries are too full, then they may not accept all the energy the VESC is generating. At which point, the voltage climbs until it finds a new way back to ground.

If using something like a high-current BMS, it may detect the over voltage and disconnect the battery, which will mean the energy really does have no-where to go no.

Most of this forum recommend running with no ‘protection circuit’ on their batteries, as disconnecting them during use is dangerous (for you and your skateboard), generally the reason is danger to the user, but hardware risks are true as well if you disconnect the batteries while moving.

So I would look seriously at your Power wiring and ask yourself if it is thick enough and short enough to carry the high currents you could produce. Do you have a BMS which may protect your batteries at the expense of other things, could you get away with a fuse.

And secondly watch out for the ‘handbrake feature’, this could be acting like an E-stop. The purpose of E-Stop is to prevent damage to the user, not the hardware, it will stop as fast/hard as it can in E-Stop.


So in terms of repair, you may get lucky here. The DRV8301 has a max of 65V. Which I would expect the TVS to be sitting at too. MOSFETS are likely >75V, and capacitors should be fine from a spike.

*Re-Test the mosfets by measuring ‘V+ to Phase’ and ‘Phase to GND’ (Red on the first), this should give you better confidence, (although from your investigation it doesn’t sound like FETs are the problem).

If you are in the UK, I would happily attempt to replace the components you have identified, as they are pretty cheap and I love trying to fix stuff. Probably not worth international postage, but I’m sure you can find a local repair man to do the magic.

2 Likes

I believe this is the most important advice we can give. I’ve streeted my face before too with a BMS that cutoff for either too much amps drawn and too much amps going back to the battery. It is not a happy feeling. All my boards are charge only BMS wired now.

1 Like