Bluetooth module with Ackmaniac's app

Hello guys, I want to use Ackmaniac’s android application and I got a HM-10 module from a local dealer and it looks like is just the Clone one… (not the clone of clone) So i figured it should be ok. But i cannot see it in your application no matter what i tried.

I see the module in bluetooth settings of my phone: is the BT05.

When i open the application i see Device V1.52 and in right part scan / stop but is not finding anything else. Any idea on that ? Do i need to flash another firmware on the BLE module ? or that wont help.

Thank you. (i have Ackmaniac’s firmware on my vesc too) Maybe someone have any experience with these clones ?

I’m using a cheap HM-10 Module as well hooked up to my VESC over the UART port and it’s working fine. @Ackmaniac maybe you have some advice for @Bloop.

I talked with Ackmaniac and he said to use the one he linked and i will but it will take a few more weeks till i get that.

Wondering if anyone else had similar problems and maybe have some advices ?

1 Like

I got this exact one, soldered the wires from my connector to the bluetooth module, and it works great, no problems at all. I made sure to insulate each connection with heat shrink as well.

All you can do is:

  1. tx and rx need to be crossed
  2. 5V should be used instead of 3.3V
  3. correct baud rate in the Vesc settings needs to be set (maybe your module has a different default instead of the 9600 - you could check via AT serial commands)

I connected at 5v also tx rx are crossed and the baud rate is at 9600 but the problem is not the transmission. The problem is that the app dont see the BLE module. And no idea how to solve that.

Some modules simply just don´t work with the vesc. So get the right one from a place with faster shipping times and change it :wink: You can find a picture of the correct version somewhere in the thread. Check that with the one you want to purchase to get the right one.

Thats the point it looks right as the one in the thread :)) So it should be the right one :-?? … no idea now maybe is a bad clone… idk

last option is to check the modul with an other vesc, but it´s more likely the wrong clone

Hijacking this thread since I seem to have a similar issue. I’ve got the HM-10 module that @Ackmaniac linked to and have it conected to the FOCBOX (3.3V).

When scanning for it in the app it doesn’t show up, however I can see the Bluetooth device in the phone’s bluetooth settings under “available devices”.

With a different phone it shows up in the app… Is there anything I can do to make it work on this phone?

Connect it to the 5V pin.

The marking on them is swapped isn´t it? 3,3V <>5V

I just tried that but with same results. Won’t show up in the app.

1 Like

not all phones have BLE tho… what phone are you using ?

i still wait for the module that ackmaniac linked and hope for the best … also got 2 focboxes… let the fun beggin hopefully ill be able to make it work

Sony Xperia Z3. I believe it does support BLE.

get an app ble checker . not sure how good ia it but it should gove you some info. also i saw on internet that some users had peoblems with ble on xperia z3.

Thanks. Ble checker said I have ble. I actually got it to kind of work. Removed the app and reinstalled it and then it worked until it lost connection (?) and never found the device… I erased all data and cache memory in app manager and then it worked again. Hmm… Don’t really know what the problem is and if it’s software or hardware related.

well could you walk me through how you hqve it setup and all? i still dont have it running. You need to set the vesc to uart + ppm or it should see the module just by connecting it to the vesc? any more vesc settings exept baud rate?

Don’t know if vesc was needed to see the device, but I had it setup ppm+uart, baud rate 9600.

Connected rx-tx tx-rx gnd-gnd vcc-5v. Removed app on my phone and reinstalled it. Restarted the phone and launched the app. If it didn’t work try clearing app data and relaunch the app.

I tried to connect again today and the app doesn’t find the device at first. Only when I first erase all app data in android app manager will the app list Bluetooth devices and connect to the HM-10.

Not the best solution, but the only way I can make it work. Sounds app related, doesn’t it @Ackmaniac?

how about trying to run it on an other phone?