Board of Prey | BuddyBuddy Freeride GT ECO Flex 1 | Dual Drive R-SPEC Uber+ | Space Cell Pro 4 | MBS-All-Terrain Wheels

I finished my first DIY-Build, mostly Enertion parts and some custom modifications, thanks to Jason and this community, now I call myself an Esk8-Builder :smiley:

Speed: ca. 40 km/h (calculated) Range: ca. 35 km (not tested yet) Weigth: 9,7 kg Price: ca. 1500 Eur Gearing: 13t:40t Motor Type: Foc (not sure If this is working well) Waiting for parts: ca. 3 months Work: 5-7 days Style: Romulan

In “normal” mode the wings hang down, it was not easy to fit them and not touching the wheels nor the ground. When I step my backfeet a bit to the front, I stand on the wings and hold them in “attack”-mode, I made this to spike the wheels of stupid segway-drivers :imp: (My first plan was to make the wings aerodynamic so that they go up at a certain speed, but this didn’t work)

1. The 90% Finished Board

2. Making of:

Drawings, Prototyping and Testing different styles

3. Media

I’ve set up a YT-Playlist on my channel for this build, there are no videos of the board yet (just preview and unboxing), but I’ll add some the next days and weeks. I’m going to mess around with the VESC/FOC settings and test how the board performs until the VESCs dies (hopefully not)

You can follow us on Instagram, I’ll spam many of the pics above there too


Lol nice wings :smiley:

thx, makes the boad hard to push, but who still pushes longboards :smiley:

The batman of esk8 has arrived ! Get yourself a matching helmet ^^. Let us know how the ribbles in those all terrains hold up against that dual r-spec drivetrain.

It looks super sick, and nice parts. I couldn’t bring myself to ride that in public though, with the wings and all, especially more cramped places. The deck itself looks really nice, but I admire your creative ideas though!

On the second test ride after a few kilometers I killed my master VESC in FOC (FAULT_CODE_DRV8302) Now I’m down to single drive and switched to BLDC. :frowning: (I know, switching from FOC to BLDC is a risk, but running FOC is a higher risk)


@E-Boarding What!? NO cloaking device? Any good Romulan ship needs a cloaking device! :wink: :vulcan:


Those phase wires are close to shorting, you should insulate them more.

That’s a really fast blow up on a vesc… Feels bad man 1 prayer = 1 less broken vesc

The worst part, my little kid with his e-go cruiser had to pull me back home, what a shame for this beast of a board…:pensive:

btw. what to do with broken VESC’s, repair for 60 bucks or selling it or laying down in the VESC graveyard?

now i want a pokemon theme board.

You could always try to replace the DRV8302 yourself. This thread could help!

1 Like

Do you have a hot-air solder station? With some caution you should be able to replace the DRV chip (about $6 from You need hot air, the DRV chip, some solder wick, and solder paste. Likely take about 15-30 minutes. Some kapton tape to keep air away from other small components (so they don’t re-flow and blow off their pads)… etc. I have a dead VESC now i’m going to do myself (from a fellow boarder here who killed it on 12s). I helped do the last 2 i killed myself.

How do you like those wheels? Your really hard on your gear(vesc) you should push to start while off-road

My second vesc is repaired and I’ve dual drive again.

I recommend to use this wheels with dual-drive, then they are good off-road

and push to start is always good

today was a bad day I was riding and at some point one motor stopped working, I got home with single drive. Opened up the battery case to check all the connections and connected both VESCs to BLDC-tool, all was fine. Then suddenly both motors were working, hm ok (overheating, something?)

After that I tried a different USB-Cable but had the wrong adapters. At this point everthing stopped working. The remote was connected (red light blinking fast) but nothing happend when pulling the trigger. So I tried to connect the VESCs to my PC to check was was going on but my PC cout not detect the COM-port anymore. I tried both vescs, 3 different usb-cables but Windows could not detect that a device (vesc) was plugged in. (the COM-port was missing in BLDC-tool) I checked windows device manager but nothing. Then I checked the power of the VESC, removed the heatsink of the slave, no visible damage, ich checked the power on the VESC with a voltmeter, 40V but there was no LED on the VESC, I thought there should be blue lights or something? Then I made a mistake and shorted the VESC, this was my fault, nice sparks…

Anyway, I still have the second VESC but same problem, not able to connect to PC and remote connects but trigger shows no reaction. I checked the channel of the remote but was fine channel 2 as before. I cannot see If the VESC blinks blue because I haven’t removed the heatshrink yet, but the reciever blinks red, so VESC is on power. Is the VESC damaged if no blue light appears when connected to the space cell?

Where is the problem? Both VESC damaged at the same time with the same strange issue? 3 different USB-cables not working? Remote issue at the same time as the COM issue with my PC?

I like to test a different VESC, I’ve 2 new Enertion VESCs on order (awaiting fullfillment for 2 weeks now) What should I do until the new VESCs arrive?

Check for fault code in the Realtime data in the BLDC tool. You probably have a DRV8302 fault code.

I can’t even connect the VESC to BLDC-tool, it seems dead but it is on power…

Your mini usb connector must be bad, thats all i can think about.