CAN bus connection problems

I’m having problems getting the CAN bus to work properly on my dual focbox setup. Originally, I had it working but at some point my slave unit would become unresponsive after a few minutes of riding. After some maintenance I found that it would cut out immediately during foc motor detection on the first step. I did some investigating and found that my CAN bus connector had almost been severed near one of the plugs. So I ordered a new CAN bus cable. In the mean time I decided that I would use a PPM splitter that I had laying around until the CAN cam in the mail. I used the wizard to set both of my focbox units as a single unit. I also updated the firmware on both units to the latest. This worked well. However, now that I have my new CAN bus connector cable I can’t get the units to communicate over the CAN connection. I’ve used the wizard to set the Master and slave unit via usb. But, the units won’t communicate regardless. I can’t even connect the configuration tool with CAN forwarding. Every time it reads “no firmware response received…” I’ve checked the setting set by the wizard a million times. Mainly the ID and CAN forwarding enabled options. What am I missing here?

1 Like

Could have burned the can chip on the pcb

How could I check this?

Have you set a different id to the master and slave vesc?

Yeah. I pretty much let the wizard do its thing on both. But setting the master as id: 0 and the slave as id: 1 is part of it.

Untick “send status over can” on the master


Thanks. I’ll try this as soon as I get home. Did something change recently with the “send status over can” option?


Should only be the slave esc that has that option ticked

1 Like

Reckon its a program issue to be sure. If you’d done the canbus chip they would both be dead as a dodo. No lights nothing. If by some strange reason the can bus is shot then you can remove the chips and they work again with split ppm.

no luck. “send status over can” was set true on the master. I flipped it and still no connection.

I took some screen shots of my settings to get the diagnostic juices flowing:





slave slave_ppm


well both work perfect as of now on ppm splitter. So are you saying that would mean that the canbus chip isn’t fried because they wouldn’t boot up?

1 Like

absolutely. If you fry the canbus then the boxes will not work at all so a programming issue it will be.

I can’t help feeling like it’s something to do with the version 3.40 firmware upgrade. Is anyone running dual vescs on 3.40 firmware?

Did the down grade but still won’t connect. Any ideas?

Veeeery similar issue here:

  • Both motors work perfectly
  • Both VESC controllers work and are updated to the same latest firmware
  • Remote and receiver work fine and I’m able to control each motor individually, wither with the remote or with the VESC tool
  • When connected via CAN bus, only the motor connected to the receiver works
  • When enabling the “CAN bus forwarding” option on the side panel in the VESC tool, the software disconnects (also gives a “cannot read firmware version” error)
  • Both motors are connected with the same colour order (yellow blue black), but one of them runs in reverse with the same motor and app configuration. I’ve used the VESC tool to reverse the motor on the app settings, but I don’t know if I should change the cable order instead (does it have an impact on CAN bus data?)

What you have explained with the motor directions is pretty normal. Mine have done the same thing. Dual motor setup, running dual ESCapes over CanBus. I just reversed the direction of the motor with the ESC tool and it’s all working fine. No real need to swap motor cables around.

The image you have posted showing the error message when trying to set up Can forward shows that you have the forwarding set up from 1. Have you tried to set this up from 0 instead? I had similar problems with mine when I was setting them up and kept getting the error message, then I swapped the ID numbers and it worked perfectly. Hope this helps you out.

Thanks! Also I’ll check the send data option, right off the bat not sure how did I have it setup (I know it is in reply to a different user but good think to check anyways)