Cant connect to torqueboards vesc

Hi So I bought this Vesc from diy electricskateboard (4.12 Hardware, software version is unknown) late November 2017 but have not had time to do the actually build until recently. I connected the vesc to my laptop for the very first time today and started up the latest Vesc Tool. After locating the correct COM port and pushing “connect” I get the following error pop up message:

The firmware on the connected VESC is too old. Please update it using a programmer.

Is it possible to use and older version of the VESC tool/BLDC tool to update the firmware on my vesc? If so, could someone please point me in a direction of which version I should be trying. Because I am afraid of “frying” my vesc by using wrong version.


1 Like


Try chucking a pm at @torqueboards I’ve only updated firmware using the tab in vesc tool on HK versions and that was fine but you’d better check first.

1 Like

They have a chat feature and are pretty quick

hahahahahah @J0ker3366 wp

1 Like

Maybe shoot a dm to @Ackmaniac as well. See if you could flash it with his latest firmware.

@3dman Make sure you download the latest VESC Tool. Sometimes you see that error if you’re using an older tool and that VESC may have a more updated firmware. You’ll definitely need to update the firmware to the latest.

thanks for the respond, folks!

Yes, I have tried diyelectricskateboard builders chat, but they could not help me. I was asked to send them a mail.

@torqueboards. I am running the latest VESC tool downloaded yesterday from VESC project. Please help me, how do I upgrade the firmware without the VESC tool? I read something online about ST2 link, is this the way to go?

if you can still connect and receive the fw too old message then you do not need STlink

@3dman - Yeah, Stlink would work for sure. Email us and we can do it for you also. Just pay shipping.

@trancejunkiexxl, when I try to connect to VESC tool I get the mentioned message “fw to old”. So how do I connect to update firmware without ST link cable and no connection with VESC?

@torqueboards, I appreciate the offer, I will probably get a ST link cable for the shipping price I would have to pay from Norway.

If your using the latest ackmaniac software it was only a matter of hitting update for me. In the event of missing bootloader I couldn’t even get the devices to be seen period… took more effort

I beleve the torqueboards vesc is shipped with bootloader as standard (@torqueboards ?). I did try the ackmaniac software as well (VESC Tool mod). But same error message.

trancejunkiexxl, can you confirm if you also got the same error message that I am facing?

You should invest in an STLink anyways, just in case something gets bricked in the future.

@JohnnyMeduse might be able to help u better. If ur short on cash and need programmer u can borrow my stlink I’ll ship it.

1 Like

@trancejunkiexxl, I appreciate the offer:-) I am located in Norway, so it might be a bit far? I just order one from the far east, but that is sent with snail-Mail…

So if it is possible to solve this without the ST link cable that would be the best!

Hello @3dman,

Can you fix this error? I have the same error I cant upgrade my firmware, could you help me please?

Hi Hansg. I ordered the stlink as suggested above, but I have not found time to finish the project or try the update. Please jet me know if you manage to fix it!