Can't connect VESC Monitor to HM-10 bluetooth

Is anyone else having issues trying to connect to VESC monitor to HM-10 bluetooth lately?

I can’t connect to any of my boards, I wonder if VESC Monitor has changed their bluetooth parameters on their latest update.

I can’t even detect the bluetooth when I click on scan.


What os are you running? I heard peeps had issues woth hm 10 and android oreo

I ordered this one.

I had issues with other modules but someone suggested this and has been solid.

turn on location on your phone, i can not find my module without location on

You probably updated to Android Oreo. You can either upload a new firmware on your module or buy another module. In case you want modules with the orinal HM-10 firmware I have some left wired up for cheap :smile:

I have android oreo and I been having issues I have hm10 module and they connect sometimes or more recently not at all :confused:

how the module shows up on your phone?

Shows up as HMsoft in fact I have problems with my Raptor 2 bluetooth also but it does work better.

That’s wierd. Where do you place the module? I had problem when it was close to the motor wires and the battery output. Since I put it somewhere else really stable connection.

That may be it cause my current enclosure is very tight.

1 Like

Me too but really few centimeters can make the different. I moved it in the center and far from the motor wires and the signal is much better. I notice when basically I was loosing the signal after hard accelerations when indeed the current rises.

1 Like

Yes… It’ll connect but no data… And if the data shows at a stop as soon as I move it freezes =\

I’ll try a phone with older OS and will report back

1 Like

As does your module shows up on the phone? Based on that it’s possible to understand which clone it is

iOS here. I use the HM10 module from Metr. It worked perfect on my first few test rides on the new build, but in two 15 miles rides, the app only recorded 2 miles and nothing after. I then used the “eSkate VESC” and “Telematics” app and they both record my entire ride.

So I’m not sure where MY problem is

Is that eSkate VESC app only available in iOS?

@Eboosted sadly, it looks that way @emmaanuel doesn’t have any plans for Android version

@accrobrandon did you solve this? Having a similar issue with a module that worked before but won’t show data now. It connects, but doesn’t show any info on the app.

No, nothing on my side

Hi, which module and phone do you have? Edit: usually the easiest test is to try to connect it with another phone. So you know whether is the module or your phone not fully compatible anymore