Starting Tips | Ask Questions | Introductions | Categories

Chaka VESC will not power motor after setting PPM settings

I received my VESC and began to set it up. I powered it with a lab power supply that does a maximum of one amp. I got my receiver and transmitter set up and the VESC was driving my motor just fine, however it was not calibrated with the same 50% throttle as the center of the transmitters trigger. So, I adjusted the min/max PPM settings until I had 50% throttle displayed. I used slow acceleration to test the motor and it seemed to work. I let go and began to pull the trigger again and…nothing. The VESC now will not drive a motor. I still get a green light. I have no fault codes. For a while after that the lab supply would not give it more than 7 or 8 volts, so I let it sit for an hour. Its now taking full voltage but still no response from the motor. I have tried resetting everything to default and that hasn’t made a difference. I’m not sure what else I can do other than send it in for repairs/replacement. Thanks for the help guys.

Green light and no fault codes mean there probably isn’t a problem with the vesc.
Your power supply sounds wonky, rule it out by using an alternate one.
Rule out the tx/rx by hooking up to BLDC tool and using the arrows keys to drive the motor.

Power supply works fine on other devices. Fluke meter confirms its fine. Also just tried driving the motor directly through BLDC with no response.

Power cycle vesc
Power cycle PC
Use another power source, maybe 1 AMP is not enough
Do another motor detection
Check motor wire connections

Done, Done. I tried a 3s and a 6s with no different results. Motor detection does nothing. Wire connections look fine. At this point I’m thinking I popped an IC and can’t see it.

Screen shots for all your common BLDC pages

I’m on my way to bed now but I’ll send them when I get home from work tomorrow. Everything was default except enabling PPM and changing the min/max. I also changed the two numbers from motor detection. I believe they were 107 and 875 ish.

Did you read your config before you made the changes?

What version of the BLDC-tool are you using? What motor are you running? Have you re-soldered any connections?

Take some pictures of your connections and post them, maybe we can see something that might be causing issues.

Hey guys. I asked my roommate to take a look at it while I was out. It appears that I somehow popped my DRV8302. I figure I must have hit the 1 amp limit on the powersupply and it tried to reset and that resulted in a spike in voltage/amperage. This also occurred a couple times while trying to do motor detection. I have heard that you should not use a LiPo to do motor detection but I can’t get the motor to spin with less than 5 amps or so. Should I use a higher amperage power supply next time? How can I avoid popping the DRV8302? Also does anyone know of the best source to purchase a new IC from and what exact model I need?

Texas Instrument DRV8302, TI DRV8302 I purchased from this site when mine was broken