Change VESC 4.12 settings without USB (port broke off) [solved]

hey folks. I know that you can flash the VESC using a st232 programmer, but can you also change the settings using the pins on the VESC using the VESC tool?

im asking because my USB port broke off and i am absolutly not able to solder these tiny pins back on.

mine did too… 2 options that worked for me:

  • on a 2xVesc setup via the CAN-Bus (Click can-forward and set the correct vesc ID)
  • Via a HM-10 Bluetooth module. I use the version from @rpasichnyk witch uses the TCP-Bridge option.

hmm, the slave thing might work. to bad i dont have a vesc with older firmware left :frowning:

ive got the ackmaniac version on it so changing Amp settings or so is easy, but if i ever want to use different batteries or motor, i have a problem

Maybe Mr P ( @Pimousse :angel: ) could help you … (not sure yet)

I’d say the same as @bevilacqua.

There is also a third (tricky) method :
Use a specific BLE module, flash it with Vedder’s code through STLink and use VESC Tool (linux only) wirelessly. This is a beta and a pretty new feature. More info here :

1 Like

the vesc whose usb port you can use to connect to the other one (via CAN) does not have to be flashed with the same software.

sweet. thx alot guys :slight_smile: