Configuration and telemetry for VESC [iOS, Android]

Sounds like iOS permission issue. Can you check in Settings app that you allow Location for metr?

Nothing changed in that matter too, I had and have it enabled… It worked flawlessly before update.

Actually very similar behavior on Android here too, I have prefer GPS in the app and have location services enabled in the phone settings and last records showed velocity but no distance which seemed strange to me, will test again in a while here and post the data it gives me.

1 Like

Could be but think that newer bluetooth version are typically backwards compatible so any 4.0 hardware shouldn’t have any problem talking to 2.0 or 3.0 devices, could be something else with the OS or hardware though (I’m on 8.0.0 here on a nexus 5x so think the software is the same as the pixel right now but not entirely sure).

1 Like

I confirm the bug. Will look today thx!


Roman i Love this shit so hard!!:heart_eyes::joy: I Test it with my Dual Vesc 6, samsung s7 and works perfekt. When you implant speedlimits at the Modus, it would be so fantastic.

1 Like

Please tell me you mean the Bluetooth on Android :smiley:

@squad @wafflejock I have fixed the problem with GPS distance calculation! Android update is out and iOS is waiting for App Store Review. Thanks again for reporting :thumbsup:

@cledus There is a thread with couple of people experiencing the same problem (I guess) Do you run Android 8?


Tried it out here for a bit and seems to have fixed the general distance issue. I still have problems with it tracking when I tell it to prefer the GPS data, it seems to only track parts of the trip, but might be something with my developer settings closing apps in the background.

First one here I didn’t have prefer GPS on

(google maps shows this as a 1.3 mile ride as well)

Second one I had the GPS preferred on

Believe this had to be closer to .6 miles or more since I did the quick test run I usually do then went around a few more blocks (also Wh vs distance wise seems like the distance isn’t making sense on this one). Not a huge deal or anything but open to tips.

1 Like

Yes I have 8.0. There is my problem. Hope it get fixed in 8.1

Updated my phone to 8.1 yesterday without any luck :frowning:

I have been loving all the data metr has been giving me about my board. Thanks for all your updates!

Yesterday I went for a ride but was shocked when I saw the scale of some of the data. I didn’t get any warnings or faults durning the ride so I decided it was a glitch and didn’t think much of it. Today I went to use my board and am getting constant over current faults causing the FOCBOX to reset after the motor barely twitches (aka unusable).

Do you feel there could be any correlation to the weird data and my ESC being fussy? I have done over 200 miles on this setup and it has been super stable. I’m going to dig a little deeper after work but appreciate any thoughts.

My setup: FOCBOX 12s 5,00mAh LiPo with SuPower BMS Turnigy Aerodrive SK3 - 6364-190KV

Looks like some super high current

Exactly! But there is no way the hardware would survive that… much less act normally for 7 miles.

Looks like some values are multiplied by 1000 (all the time). What version of the firmware are you running? Can you connect with USB and run a bench test to see if BLDC Tool (or VESC Tool, if you are using new firmware) also has x1000 or not?

I’ll be checking it out tonight and I’ll report back. My goal with a 12s system was to keep currents low :stuck_out_tongue:

I remember I already saw some faulty values in this topic (not such mad as yours but the idea is the same). Once VESC was connected to BLDC Tool, it displayed the same garbage. Which leads us to conclusion that VESC has gone crazy and needs repair.

Hey @rpasichnyk i was thinking about a cool feature. We mostly use eboards for commuting and records back and forth create a lot of them and when you wan’t to find a specific ride it’s not easy when you record a lot.

  • create files to separate the type of rides : commute , fun ride

And for the commute record i would like a feature to « consolidate » two record like one since it’s basically the same ride, just a few hours later when you have to go home.
What do you think ?

Just got off a screen share with Enertion support and they will be sending me a new FOCBOX. I had fortunately purchased the warranty as I have had bad luck with first tries with new hardware. So no new info/conclusion, but am itching to get back on my board.

metr has been great though this process. thanks!


@rpasichnyk Would it be hard to make an Pin(lock) option for the web interface so it doesn’t move along with the mouse cursor ?