Controller only changes VESC LEDs

This is stumping me, even after doing a lot of searches. Brand new build. It’s a dual-motor board, but I’m just working with one VESC/motor to start my testing.

I have the battery, VESC, and motor connected. The BLDC tool seems to test the configuration just fine, and spins the motor. However, when I connect the controller (torqueboards nano), it syncs just fine, but won’t drive the motor. The blue LED is always lit. When I pull the throttle down and hold it for a second and release, the green LED lights and stays on. It goes out if I push the throttle up and hold it for second, then release.

What am I doing wrong here? It’s driving me crazy.

Please send a screenshot of your BLDC tool config.

This screen?

Go to the app configuration tab.

Under General make sure it is set to PPM

Then go to the PPM tab.

Under this tab you will want to check the box that says display. That will show you the input signal you are getting from the controller.

Setup the max and min values appropriately. See this:

Then set the mode control mode to whatever you like.

Most people seem to prefer ‘current no reverse with brake’ or ‘current’ (which has reverse)

Thanks @tim_felbinger. It was set to PPM. On the display signal area, it shows full reverse throttle at 12% and full forward throttle at 81%. Still, I don’t get any motor action with the remote. Just the LED action described earlier.

You need to select a mode, its probably set to “Disabled”. The most common mode is “Current no reverse with brake”

You’re running sensored mode, but your hall sensor detection is failing, which usually means you don’t have sensors plugged in. If you’re not using sensors make sure to change the motor mode to unsensored.

I am just leaving the sensors disconnected while I’m connected to the BLDC tool because plugging them in disconnects it from the BLDC tool for whatever reason. I’ve tried them in both sensors and uncensored mode.

This is weird though. Pulling the remote backwards definitely applies the brakes. So it’s just having a problem supplying power forward. It freewheels fine, just doesn’t spin the motors.

plugging them in should not affect bldc tool. Are you sure the wires in the right place? Maybe you’re shorting something out when plugging it in… If you do leave them out and have it in sensored mode, it definitely wont run.

You should probably also post a pic of your motor tab as well

I agree. There has to be something weird going on. I was able to get it to connect to BLDC for a short while even with the sensor wire plugged in, but when I tried clicking “start detection” the motor gave a little lurch and stopped and the VESC disconnected and now it won’t reconnect unless I disconnect the sensor wire. Here’s my motor tab.

And here’s all the physical connections themselves.

Your sensors are plugged into the program/debug port… the hall sensor port is under the red/black power cables in your picture. You’ll want to make sure each pin is also in the right spot as they’re not usually in the right spot from the factory.

I mean the motor tab not the BLDC tab. Also your motor wires should be facing the opposite direction and ‘U-turning’ back into the enclosure if you want them to last.


MANY thanks! I didn’t even notice the port under the power cables. I was planning to turn the motors so the wires face the other direction, but was trying to figure out how to get the parts all working first. I’m guessing this will do it. I’ll try and report back. Thanks again.

no problem, just make sure you plug in the vcc,gnd,temp, and sensor wires in the right order. The three sensor wire order doesn’t matter but the vcc,gnd, and temp do.

Thank you! Looks like things are working now as expected. I had to play around with the BLDC settings a bit, but things look good. Thanks again so much.