Did I just brick my Focbox? Heeelllppppp!

Ok, I updated my Focboxes to 3.40FW, run the motor wizard and the input setup wizard. The update was performed using the TCP bridge on the metr.at app. Everything seemed to work fine. I started experimenting with throttle curves (no belts attached), I am not sure what happened but at some point everything stopped responding.

Now my master focbox can’t connect to the VESC tool.

The slave connects fine with the USB or with the metr module (if I connect the module to the slave) It does not matter whether I try to connect via the metr pro module or directly with a USB cable.

Before anyone asks me, I did not at any time disconnect the CAN cable.

I have my new SurfRodz with psychotiller mounts and six shooters coming tomorrow and the bloody thing does not work (AGAIN :face_with_symbols_over_mouth:)

There are any red lights blinking on the one which not respond?

No, only the blue light is on, same as the other one.

Guess you already restarted it many times. Did you try to disconnect the can bus and get connection if it’s a single unit? The usb cable work on the other focbox, so it’s not the reason… Maybe also try to disconnect the bt module and try only to connect via usb.

I have tried all of that. Nothing worked.

St v2 link would be an option.

1 Like

Check then actual usb port on the focbox. Make sure there’s a solid connection. I had to remove a bit of material on my plug to get it to connect reliably

1 Like

I have tried multiple USB cable, some with a longer connector. However it is definitely not the port since even the metr.at pro module does not work.

Yeah, I have thought about that. Unfortunately I do not have one and it would take weeks from one to arrive from China. Even then I hope flashing a new bootloader and firmware would solve the problem. Anyway it seems I am screwed :disappointed:

This is the exact same fucking thing that happen to my Focbox two days ago. The Metr Pro fucked it. However the only thing I did was to “read” motor config. It gave an error, and what you know. Master went only blue lights.


Did you manage to repair it?

My board was working perfect , until I open the app and did read config.

1 Like

Where you located?


1 Like


1 Like

Waiting on the St-link.

Crap, I did the same thing to check if all my config was sent to the focboxes. I got a message saying the app is not yet compatible with the firmware and next it did not work. I never thought it could have caused the problem.

1 Like

That is exactly what I am seeing.

1 Like

I had ack 3.102. It worked with the app, I got data , etc etc . But this happen at the modes area.

I was looking to make a mode. So I did “read” It loaded the information. Then gave an error. And disconnected.

Well I did most of the research. Apparently you get the

  1. Get a st-link
  2. Wire it to the box
  3. Download the utility
  4. Load hex file
  5. Load default VESC firmaware
  6. Update firm of your choice via USB.

Hopefully that works, either way I looking purchase another Focbox soon.


Happened to me the same on Flipsky 6.6. I think right after I read the configuration from metr.