DIY 12s esc brakes will not adjust

On the lowest settings the brakes throw me off the board. Using the steeze remote… Any ideas?

The problem is the remote Those brakes work better with the Diy mini RC remote

1 Like

Cool, thanks!

I was able to run my brakes at 100% with that Esc and the mini remote. From what I’ve been hearing lately, the Remote makes a big difference with any Esc including the Vesc. From experience I can say that IMO, the nano remote doesn’t work as well as the mini with the TB ESC. And the mini RC remote works extremely well with the Vesc.

1 Like

That’s odd. The remote will be sending the dang pulse width but the ESC is supposed to change that info… It’s probably an issue with the ESC.

@torqueboards might be able to shed some light on this.

I tried a mini r/c, still throwing me off…

It’s gotta be the ESC… Are you sure it actually set the value for braking? I haven’t played around with mine yet.

Yep, I put them on 10%, no change

What firmware are you running on the Esc’s ?

Not sure, I sent it back to DIY…

Trading it in on a Vesc?

possibly. I like how robust the 12s esc is, but in my limited use of it, it seemed loud and the throttle a bit sloppy compared to my vesc…


Do you consider your ESCs to be loud and have a sloppy throttle?

I’m running Vesc’s now but when I was using the TB’s Yes they where loud when I had them mounted outside the enclosure. They where much quieter when I put them inside the enclosure. I was using the RC Mini Remote that TB sells with them and it worked very well IMO. I don’t think the steez remote is as good.

1 Like

Did you ever solve this? I’m having the same issue. Cannot get the brakes down to a usable level.

yep, I returned it, exchanged it for a vesc…

Got mine fixed, had firmware version 160606, put version 150818 on there and everything works wayyyyy better.

1 Like

Do you mind sharing the settings from the program box for your brakes, etc? Mine has 13 settings. Need to check what FW version are mine. It’s throwing me off my board even at slow speeds.

I would make sure you have the right firmware version first, unless you have that the settings don’t matter.

1 Like

Thanks @Cisphyx I don’t know where to get back my old firmware. Now it is just having quick constant beeping noise. I was running Software Ver: 1.00_160606 and had tried out the

the ESCs I got were from @barajabali

Can you or anyone else link me to the correct firmwares? It was originally running fine except I wanted to have smooth brakes. Now it won’t even run with those constant quick beeps from the motors (Rspecs)