Do I have a dead FOCBOX?

Hey guys, so I’ve got a focbox that is flashing the fault light in sets of 3 repeatedly. I initially understood this as a sign the DRV chip was bad. So I desoldered it and replaced it. The ESC powers on but is still flashing the fault light. I can connect to it just fine but when I try to do a motor detection it said “Bad Detection Result Received”. I should mention that I was given this FOCBOX by a friend who tried to desolder the motor leads and solder the bullet connectors right to the board. He told me his soldering iron wasn’t getting hot enough and he had to leave the iron on the board for quite awhile to get the solder to melt. I’m guessing he fried something but I’m not sure what. If anyone had any advice I would greatly appreciate it. I already tried asking both @CarlCollins and @JohnnyMeduse but I’m guessing they are either busy or not sure as I haven’t heard back from them. imageimage

does it appear when you connect it to your pc and open the bldc tool?

Try upping the duty cycle and trying again

yup, it shows up in BLDC and Ackmaniacs tool. (its currently running FW 3.102)

that doesn’t seem to do anything, I bumped it up from .05 to .1 and then to .15 (not sure how far up to go using Ackmaniacs tool for the configuration.

One of my motors only detects on .2 and the other on .15 so maybe take it up another increment. Check the fault window.

Nope, still a no go… here is the debug console: image Also, the fault light on the FOCBOX is still flashing in sets of 3 even while I successfully update other values on the ESC such as voltage setting and what not.

Hello everyone. I am very new to this website and am very sorry to intrude on your conversation, but I just have one question to ask myself. Do you know how to start a thread? I have a few problems I need solving. :sweat_smile:

I sent “threads” and “mem” to the terminal in the Ackmaniac tool and here were the results. I don’t know if any of this is helpful in determining the issue but I don’t know what else I can pull out of the ESC other than this. image

@jojamcha you go to the “new tab” and on the top right select “new topic”

go onto bldc tool and go to terminal. type “faults” and press enter. what comes up?

No faults show up when I send the “fault” or “faults” command in the terminal :frowning: BUT, I was looking more closely at the board and realized that my a one or more of the cap resistors next to the DRV chip had been moved… so I took a few min to clean them up. (added flux and carefully tried to get them back to original position) there was also a stray wire (single strand) from the receiver wire that was touching one of the cap resistors that I got out of there. After that (and a good cleaning with isopropal alcohol the flashing fault light has now gone away!!! I tried to run the motor detect again with the duty cycle set at .05, .1, .15 and .2 but I’m still getting the same message “2018-10-15 21:19:00: Status: Bad Detection Result Received”. I definitely feel like I’m moving in the right direction though :slight_smile: any other tricks to get the motor to detect?

1 Like

When I do run a motor detect I can see the signal light on the FOCBOX gets brighter twice but the motor never spins. What are the chances the fets got overheated and one or more of them are bad? Does anyone know if its possible to test them to see? They look physically fine but my buddy said when he was trying to desolder the phase wires he burned himself on the heat sink because it was soaking up all the heat from his soldering iron that was passing through the fets…

I saw this message by @Martinsp but I’m not really sure what he is suggesting. I just to see if the mosfets are damaged from overheating. They look fine but the motor won’t detect, and like I said I’ve tried changing the duty cycle from .05 up to .2 with no success. (how high is safe to go up on the duty cycle?)

Try testing in FOC. Had issues with my FOC box detecting in BLdC

So I’ve never tried to and though maybe it would work. I hooked up the sensors too for good measure. When I click the box circled below I got this message. (this motor works fine with my other FOCBOX) Does this mean something to someone else? I’m not sure yet what it would mean. image

Never seen that error before

I’ve only seen it referenced once before by @Eboosted but he never mentioned if he got it fixed or not… I sent him a message awhile ago to see if he did or not. Fingers crossed he’s got a better idea whats going on :slight_smile:

If your have a flashing red light on the Focbox, you need to repair it or replace it, unfortunately there’s nothing you can do. I suggest you get 2 Focboxes one for inmediate replacement and one as spare. Having a board under service waitiong for parts it’s the worst thing an esk8r can experiment, that’s why I have have 5 now only 2 working and 3 under service :smirk:

1 Like

bummer :frowning: so did the FOCBOX throwing the “L is 0” error get repaired or just replaced? I was talking to CarlCollins and he said after talking to his RA the issue has to do with a short on the DRV which kinda sucks cuz I just replaced the DRV. If I can’t get this one fixed I gues it will just be a parts ESC lol but it would be nice to get it fixed and have a spare as you said. I do have another FOCBOX so I’m not dead in the water (just went for a nice 5 mile ride… love this thing!!) but I’d also not like to see the money wasted.

1 Like

Replace the Focbox and enjoy, forget about everything else :sunglasses: