DRV issue or something else?

Hey guys, I build my first board and it worked great for the first 2 mins of its life until suddenly it stopped, what happened was I tried to go up a gentle incline for my maiden voyage but I rolled back probably 1 meter and suddenly the motor wouldn’t spin anymore tried to reset, reconfigure motors, recheck connectors, etc. I linked a video of me showing the real-time data from the VESC tool when running different “experiments” on it and the flashing lights on the VESC. My first doubt was the “regenerative braking” might have fried something on the VESC, but a 1-meter rollback?? The setup uses a Turnigy 6364-245 motor, VESC and speed controller from TorqueBoards (DIYelectricskateboard) and a Turnigy 5000mAh 6Cell 22.2V battery. [https://www.youtube.com/watch?v=PW8QiJSwA1E] Please guide me on this, its been ages and i just want the damn thing to work this summer :frowning:

Try reflash the firmware and try again

Just re-flashed the firmware, got the motor detection to spin the motors albeit taking its sweet time to register anything before doing so, went through the control setup and tried using the keyboard keys…no response in either :confused: I took a screenshot of a few of the errors that popped up on the command line if they help?

I don’t know much about this but you can try to reconnect motor. I have different esc but worked for me.

Did you check the setup motors FOC ? Do you have sensors on your motor?(a 4th cable with 5-6 smaller cables ?) if not you should change the sensor port mode on the VESC tool (at 1:01 on your video)

If i’m not mistaking your using a Turnigy Aerodrive SK3 - 6374-192KV Brushless Outrunner Motor(https://hobbyking.com/en_us/turnigy-aerodrive-sk3-6374-192kv-brushless-outrunner-motor.html?queryID=6bafc8633e752717ae8a7b14215b21a9&objectID=17322&indexName=hbk_live_magento_en_us_products) the voltage is 10-12s(36- 42volts) maybe you should try to connect 2 of your turnigy 6s (in series) also put the max wattage at 2750W and the max load at 80A like it’s said on the spec sheet.

personnaly the first thing i would do is change the parameters on the VESC tool and use 2 6S batteries in series

Hey Josh, so do go through your points in order, if i am not mistaken FOC and BLDC differ in the motor you use and i figured mine might be BLDC and therefore i didn’t setup on FOC, the motor didn’t come with the Hall sensors (only 3 cables out of it), but the sensor port mode doesnt have a “None option”, so i left the default there…

The motor is a 6364-245kV: ( https://hobbyking.com/en_us/turnigy-aerodrive-sk3-6364-245kv-brushless-outrunner-motor.html?___store=en_us)

The battery is a single unit that i bought to avoid having to pay multiple unit duties to canada, its a Turnigy 5000mAh 6S 25C Lipo Pack w/XT90: (https://hobbyking.com/en_us/turnigy-5000mah-6s-25c-battery.html?queryID=cece5fc5c661cd93e77f20eda5e5721b&objectID=72233&indexName=hbk_live_magento_en_us_products)

Does this change anything? a little few tidbits of info too, i had to re-flash the boot loader using a STM programmer as it wouldnt update to let me use the new tool and the entire test ran smooth when i had the battery on “storage capacity” and after i did a full charge to use it outside, its never worked.

1 Like

Ok, sorry I saw your feed back but I was at work :,) and couldn’t check something.

So you could try to put it back to FOC in the General motor setting then go in the FOC (under the General button) to change the sensor mode to sensorless

then Motor resistance to 0.018Ohm (18mΩ)

the others honestly idk what it is (you’d have to check on the manufacturer datasheet)