Starting Tips | Ask Questions | Introductions | Categories

Duel VESC behaving differently when connected to the BLDC tool

Hello everyone

Im new to the electric skateboard world. My current setup is dual torque board 6355 motors with duel 4.11 VESC connected through CANBUS with 6S battery and a nyko kama controller. Firmware vs is 2.16

Motor detection worked great. I switched from FOC back to BLDC to regain the cruise control. My problem is when i have the motors spinning on the bench connected to the BLDC tool on my MAC everything works great. The problem is when i disconnect my set up form my laptop the motors will spin but suddenly one will cut out and loose power and the other will continue to spin. Or they will be spinning and one will cut out (usually the master one first) then the slave will cut out.

I have tried switching which VESC is the master and which one is the slave.
The connections on the Kama are soldered
i tried reloading the firmware.

I don’t think its the Kama receiver causing the issues cause it works fine when plugged into and connected to my laptop.

I could really use some help


1 Like

After a cutout, reconnect to bldc tool and type “FAULTS” in the terminal window to get list of faults since last boot. That may or my not give you a clue.

What do the leds do when this happens ?
Any chance of a video ?

I checked. There are no faults.

The led on the VESC goes from white to blue when the cutout happens.

After playing around with it for a while this morning i believe the cutouts are due to interference with the kama. If i press the throttle up and hold the cruise control and hold the kama still the motors will cutout. Oddly enough if i move the kama around in my hand (just back and forth) i never get the cutouts. It only happens when i hold the kama still in my hand. I spent a good hour trying this out.

Sounds like you may be hitting the inactivity timeout which sets the motor (brake) current to a preset value (default is zero) when the accelerometers in the kama don’t detect movement for a preset time. Check those settings, perhaps up the timeout a bit.
This may be a problem on the bench which won’t be one when riding, you never keep your cotroller completely still.

Yea that did it. I increased the timeout. Works perfectly. Thanks

1 Like