Earthwing, Mboards 6374, 12S4P, Flipsky dual fsesc 6.6 plus, Flipsky vx2 pro

Hi everybody, I’m towards the end of my first build and have struggled this far on my own without the wisdom of all you enthusiasts out there. But now I’m at a point where i can’t seem to get by on my own.

I’ve actually gone through all the drama of figuring out all the compatibility issues. I’ve got enough spares now to almost build a second board with all the bits I’ve got that i had to buy again because the original bits weren’t quite right for my build. I’m down to configuring my vesc and pairing my remote. I have downloaded the vesc tool, updated the firmware, done the motor wizard and now I’m trying to map my controller. whenever I try to map the controller it doesn’t seem to put out any reading on the rt meter to get numbers to apply. I push the wheel and the motors make some weird noises and struggle to turn. I get the message to turn on the rt app which i think I’m doing, but still don’t get any better response.

I have got the flipsky 6.6 plus, with the flipsky vx2 pro remote running an Mboards kit with 6374 motors on a 12s4p.

I’m stuck unsure what part of the process I’m missing/doing wrong.

any ideas?

Is your controller paired to the receiver at this moment? How did you wire the receiver with the ESC? Have you some pictures?

I’m not using the ppm port as it has the wrong connector for the receiver so i have put it in the comms port (5) next to the blue tooth receiver (6).

It does seem to have connection with the fsesc, it makes noise and the wheels do turn. But it sounds awful and the wheels only spin in reverse. You cash see the motors try to spin forward but they seem stuck somehow. They worked fine in the motor wizard when I did the detection test and the polarity was good when I tested forwards and reverse. It just seems to be the remote having trouble communicating properly with the vesc.

He’s become one of us


Did you have the remote on during the detection?

Motor detection? I don’t think I have. Should I give that a go?

I had a go with the remote on. Same result.

No do it with it off run motor wizard. Then setup input wizard.

I’ll have a go.

I watched your video. Run all the things again. After your done disconnect from vesc turn on the remote and should be good. Probably. Maybe.

1 Like

I tried again with remote off for motor detection, power cycled then did the input wizard and had the same result. I noticed that when I did the video when it came to the pulse length mapping I forgot to select current.

When I did it again and selected current, vesc tool read (-300.0%) without me putting any input from the remote.

Sorry for poor quality photos.

Is your remote receiver the right one? Don’t change the thing to current. Current no reverse with brake.

I’ll have a go.

1 Like