Enertion Brand new Focbox no( power/fault/signal) indication lights

Ok any help would be appreciated. First time board build with dual motors.


  • 2 Hobbysky 6374 Motors;
  • 2 Enertion Legacy Focbox; and 1 Enertion Nano-x controller.

So the build seemed straight forward enough but now trying to get power to the two Focboxes is where im having a problem. The battery has 49.5 volts. The battery splitter going to each focbox has 49.5. Now here’s where I loose it. The focboxes do not light up at the Power/Fault/signal indicator light.

Here are the voltage readings I can get from my Master and the slave Focbox.

7 Pin Connector Markings On The Focbox Master Slave 5v pin actual readings 5.13 volts 5.17 volts 3.3v pin actual readings .131 volts .033 volts|

5 Pin Connector Markings On The Focbox Master Slave 5v pin actual readings 5.17 volts 5.17 volts

As you can see there is a large discrepancy between the 7 pin connector 3.3 volt marking on the Focbox and the actual readings. Again these Focboxes were purchased direct from Enertion just last year. Never got them to power up from day one, and I did buy the extended warranty but expired 10/19. Any help would be appreciated.


Did you connect to Vesc tool and check for faults? Also make this same post on the esk8news forum, you will get a lot more active people on that forum

Thanks will do but yes tried connecting to vesc tool and would not connect. Actually tried two tools