Enertion Raptor | Understanding VESC Programing Defaults | Effects of Making Changes

I think you meant to say have the battery cutoff start set higher. Yes this make sense.

I simply never bothered to do it because I never road up hill when its near empty… Like I said STUPID MISTAKE.

If the battery cuts out because of the BMS LVC when you are riding on flats or slight downhill there really is no problem, you no longer have power, you just start coasting…

@onloop Thank you for sharing the technical infomation. I hope to see more of that in this thread!! :stuck_out_tongue_winking_eye:

This is truly amazing service!!! It solidifies the positive feeling I have about your commitment to customer service, and my choice to give you my business.

I hope users that taking advantage of this service share their results, settings, and general experience here.

Yes, thank you. Anyway, as a future Raptor owner I appreciate the efforts to make these boards great. I’ll stop high jacking the thread now.

i have not had any issues with it… i also ride with the lid on.

This graph is interesting because it highlights one major difference between 18650’s and Lipo… when the voltage sag begins! Below is a graph that @trbt555 posted in this thread. Here it looks like the drop starts at 3.6v for Lipos.

1 Like

Well, I’m having issues making this appear as a quote from onloop, (I’m on my phone at the moment) perhaps a mod can fix it…

My instructions to reduce the aggressive low-speed power of the raptor.

NOTE: please test with lid off first! This is to make sure your problem is not related to poor signal, if nothing changes with the lid off & the signal seems responsive its fair to assume you can get some results with the below instructions.

1. Reduce motor current. - See “Motor Max” change this to 40- To reduce the brake force, change “Motor min (regen)” - this is also rider weight dependent. Maybe try -10 or -20 to get it perfect you will need to use trial & error.

2. Re-tune or customize the PPM settings.- Adjust the “Soft RPM Limit” settings- Increase the Deadband

Watch this video too:

3. Limit Top Speed using RPM limits
You might also try setting the ERPM Limit Start at 20000 This will start limiting the Speed at around 10km… Could be a good idea until you get your bearings.
Otherwise maybe try these settings below…
Its really up to you. You can tune this to meet your expectations.

1 Like
1 Like

i managed to get the drivers running and started bldc. i even managed to connect but it won’t let me read out the configuration. also in the corner it says “connected, limited”. someone seen this before?

You need v1.14 of the bldc tool, it will match the fw version of your vesc


I don’t recommend updating your fw for now, you can end up damaging your vesc or bricking it.


perfect, thank you it worked!

@Xusia have you gained any remote specific knowledge beyond the channel switching information posted by @onloop? I’m wondering in buttons A or B may be used for cruise control or if that function is limited to the C button (throttle).

Hi Thom,

I would say I have gained some knowledge - about the VESC settings (and this definitely beyond the channel changing). The settings you are referring to are remote specific and therefore if they are available would likely be found in the remote receiver firmware/software.

In my humble opinion, however, the buttons are good as is. It’s actually quite natural to just press down the stick when you get it where you want it. Having to press “B” would mean holding the remote differently (for me, awkwardly), and what if you accidentally also pressed “A”? Or just had your finger up there and pressed “A” long enough to turn it off? Not a good idea as far as I’m concerned.

I posted my results in the First Batch Problems & Solutions thread, along with a couple videos. I definitely recommend that anyone not 100% happy with the remote check out these settings and make appropriate adjustments. Just changing the settings by .1 made a HUGE difference!

I’m happy to help you if you want.

i’m not sure what i’m talking about, i just watch a lot of videos. so if this is stupid please ignore it :slight_smile:

has anyone tried fiddling around with FOC? like his: https://www.youtube.com/watch?v=bYYNbxPXNEU

it seem’s it was the key to okayplayer’s (esk8fr) “problems”. he tried all sorts of setup’s until he finally got the desired results with FOC: https://www.youtube.com/watch?v=HGdswPPROWs

here’s another example how smooth it can be: https://www.youtube.com/watch?v=Uvelb52XICU

is this possible for the raptor dual or was there some info about this that i missed?

because of non stop rain i went to the close by tunnel to give the new settings a quick run.
i can now accelerate really smoothly! but now the motors turn off as soon as i’m over 1/4 throttle: https://drive.google.com/file/d/0BybdY5w-PsmIRFlscmlkNGNiOXM/view?usp=sharing (10 sec mark, battery above 90% charge)

i did not change the battery settings as suggested above.
i did however apply the settings @onloop posted about lowering aggressive low speed.

any idea which of the settings could have caused this? is it motor max which i changed from 80 to 40?


It looked like your LCD display died too, not just your motors. This seems like the low voltage cutoff is being hit, but I’m not sure. Were you going uphill at all? I’d think the new setting should make thisnless likely, not more. Have you tried it during a bench test and if so what’s the result. I think you said your battery (like mine) wouldn’t turn on. You had to charge it first, right? Maybe someone can tell if this is an after effect of that. Maybe the battery is week from a prolonged period of low, or under, charge. Maybe the weakness makes it morenpron to voltage sag, I don’t know? Just a thought. Can anyone tell me if I’m a complete idiot for thinking any of this?

this was on a straight. same happens on the bench: https://drive.google.com/file/d/0BybdY5w-PsmIR3I1REtYZ1BDTkE/view?usp=sharing (on the bench i can’t accelerate slowly, so it instantly cut off as soon as i hit the throttle)

battery has a funky switch which i have to press just right in order to hold, that is the problem. i don’t think the cut off it battery related. i have to toggle the power off and on, kinda reboot, to start it again opposed to just turning on.

I can’t say for sure, because I just don’t know enough about the battery electronics, but that sure looked like the LVC kicking in. How charged was the battery? Also, what was it flat or were you going uphill?