Starting Tips | Ask Questions | Introductions | Categories

Enertion Raptor | Understanding VESC Programing Defaults | Effects of Making Changes

i managed to get the drivers running and started bldc. i even managed to connect but it won’t let me read out the configuration. also in the corner it says “connected, limited”. someone seen this before?

You need v1.14 of the bldc tool, it will match the fw version of your vesc

http://vesc.net.au/BLDC-TOOL/Windows/OLD%20Versions/

I don’t recommend updating your fw for now, you can end up damaging your vesc or bricking it.

2 Likes

perfect, thank you it worked!

@Xusia have you gained any remote specific knowledge beyond the channel switching information posted by @onloop? I’m wondering in buttons A or B may be used for cruise control or if that function is limited to the C button (throttle).

Hi Thom,

I would say I have gained some knowledge - about the VESC settings (and this definitely beyond the channel changing). The settings you are referring to are remote specific and therefore if they are available would likely be found in the remote receiver firmware/software.

In my humble opinion, however, the buttons are good as is. It’s actually quite natural to just press down the stick when you get it where you want it. Having to press “B” would mean holding the remote differently (for me, awkwardly), and what if you accidentally also pressed “A”? Or just had your finger up there and pressed “A” long enough to turn it off? Not a good idea as far as I’m concerned.

I posted my results in the First Batch Problems & Solutions thread, along with a couple videos. I definitely recommend that anyone not 100% happy with the remote check out these settings and make appropriate adjustments. Just changing the settings by .1 made a HUGE difference!

I’m happy to help you if you want.

i’m not sure what i’m talking about, i just watch a lot of videos. so if this is stupid please ignore it :slight_smile:

has anyone tried fiddling around with FOC? like his: https://www.youtube.com/watch?v=bYYNbxPXNEU

it seem’s it was the key to okayplayer’s (esk8fr) “problems”. he tried all sorts of setup’s until he finally got the desired results with FOC: https://www.youtube.com/watch?v=HGdswPPROWs

here’s another example how smooth it can be: https://www.youtube.com/watch?v=Uvelb52XICU

is this possible for the raptor dual or was there some info about this that i missed?

because of non stop rain i went to the close by tunnel to give the new settings a quick run.
i can now accelerate really smoothly! but now the motors turn off as soon as i’m over 1/4 throttle: https://drive.google.com/file/d/0BybdY5w-PsmIRFlscmlkNGNiOXM/view?usp=sharing (10 sec mark, battery above 90% charge)

i did not change the battery settings as suggested above.
i did however apply the settings @onloop posted about lowering aggressive low speed.

any idea which of the settings could have caused this? is it motor max which i changed from 80 to 40?

cheers

It looked like your LCD display died too, not just your motors. This seems like the low voltage cutoff is being hit, but I’m not sure. Were you going uphill at all? I’d think the new setting should make thisnless likely, not more. Have you tried it during a bench test and if so what’s the result. I think you said your battery (like mine) wouldn’t turn on. You had to charge it first, right? Maybe someone can tell if this is an after effect of that. Maybe the battery is week from a prolonged period of low, or under, charge. Maybe the weakness makes it morenpron to voltage sag, I don’t know? Just a thought. Can anyone tell me if I’m a complete idiot for thinking any of this?

this was on a straight. same happens on the bench: https://drive.google.com/file/d/0BybdY5w-PsmIR3I1REtYZ1BDTkE/view?usp=sharing (on the bench i can’t accelerate slowly, so it instantly cut off as soon as i hit the throttle)

battery has a funky switch which i have to press just right in order to hold, that is the problem. i don’t think the cut off it battery related. i have to toggle the power off and on, kinda reboot, to start it again opposed to just turning on.

I can’t say for sure, because I just don’t know enough about the battery electronics, but that sure looked like the LVC kicking in. How charged was the battery? Also, what was it flat or were you going uphill?

above 90% charge, flat, see my last post for video on bench please :blush:
edit: i did charge he battery. until the green light appeared on the charger as suggested in onloops video.
also keep in mind that i didn’t have this before i changed the settings. so the battery seems ok.

Sorry - your post came in as I was typing mine. I didn’t see it.

Based on that, you have a defect somewhere. My guess is the battery. Do you have another ~37v battery lying around to test with? Or another Raptor owner close by?

i will hopefully when thom is back and he still want’s to do so :smile:

before i changed the values in the BLDC tool, i was one of those who reported he couldn’t maintain lower speeds. i could however drive it without cut offs and it had the full torque.

now that i made the suggested changes, i have the problem with the cut offs.
do you think these two problems could be linked? or does this just show i’ts not the battery?

Hmmm. Not really sure, but based on that I think it’s worth looking into. If you care to hook it up to the BLDC tool again, can you tell me:

  1. The values of remote at full backward, neutral, and full forward (should be 3 values, each higher than the last)?
  2. The Min & Max Pulsewidth values, and the Deadband value?

Did you make any other changes? Also, did you visit the the motor config page, and if so did you first READ the config, before clicking Write? If not, you might have written some incorrect values. Maybe take a screen shot of that page so I can compare to mine?

thank you i will provide these values (and screenshot) as soon as i have the board again tomorrow.
i did not make any other changes and i did read the config first before i changed anything

I’m definitely willing to do whatever I can. I’ve made arrangements to have my next Enertion package delivered (after I return from Sweden) Wednesday. I will only be in Switzerland 2 days before heading out to Dubai. I’ll return on the 25th. You are welcome to my battery or anything else before then, but you’d need to come down. I won’t have time to come up to you. Also, keep in mind my battery seems to have issues itself.

On to the issue at hand though. I suppose it’d be easy enough for you to change back to your default “out of the box” settings, right? If so, give it a try and see if the apparent battery issue is still present. Had you ever opererated the board with the battery at 90%, or less, on the old settings? If not, it’d seem even more likely, to me, this is a battery issue that simply hadn’t had the opportunity to show up until now. I don’t see from what you mention how those settings should allow you to draw enough power quickly enough to hit the low voltage cutoff and not blow a fuse or something. I may be wrong, of course, I’m very far from an expert on the matter.

Maybe try seeing what it says the percentage is before it cuts off. Does it jump from 90% to 0% or does it hit levels in between. If levels in between maybe there is enough time to test something else. I’m curious if your able to “slam on the brakes” and send voltage back to the battery quickly and prevent the shutdown. Not sure what it would reveal if that was the case, but it’s possible it might help diagnose the issue with someone more knowledgeable. In any case I don’t understand how the motors could request enough energy on the bench to hit the low voltage cutoff of the battery when it’s showing 90% charge on the LCD, regardless of the settings, without blowing a fuse. I mean, if a fuse serves a purpose it seem it should blow before then, right? Maybe the amps needed to blow the fuse aren’t enough, but I thought pulling amps quickly during load is what caused the low voltage cutoff in the battery to hit. This of course was when th battery was low. At 90%, it’s not low, right, so more amps drawn (quickly) before hitting the low voltage cutoff, no?

Anyhow, it seems clear the issue is in the battery, to me. I just can’t seen a 90% voltage reporting battery hitting the low voltage cutoff otherwise. I mean the VESC can’t shut down the battery, right? Only the BMS can do that automatically, correct? Is there an instance where the BMS will shut down the battery while voltage shows capacity at nearly 90% other than hitting the low voltage cutoff? If not, are there any settings you could (incorrectly) put into the VESC to demand enough from the battery that it would hit the low voltage cutoff while reporting nearly 90% charged according to voltage?

Hopefully someone knowledgeable comes in here and can clear it up for you soon. I’m really anxious to learn about this.

If your LCD is turning off it this is wire into the battery before the vesc. this could mean a few things,
your pulling more amps then the BMS is set for, or the voltage is to low and the LVC as kicked in and also if there are to high charging amps and the bms is trying to discharge the battery but can’t do it fast enough so it will cut off the bms.
If your BMS reaches its amp limit you have to charge your battery for 20mins to rest your BMS.
but you will know if this has happened because the lcd will not turn on at all.

i have found that the exertion 4A charger will continue to charge your board well after the lcd says 100%.
the 2a charger light will turn green but if i plug in the 4a charger it will continue to charge.

so you might want to keep the charger charging longer maybe 1 hour after the green light turns on.
the 2a charger should take 4 hours to charge your battery.

as for battery you can also damage or the bms if you bomb a hill and apply brakes while on a full charge.

Center stick: 1.554 - 1.560
Full Brake: 1.183 - 1.189
Full Throttle: 2.007 is the last number shown before the board turns off again

screenshot: https://drive.google.com/file/d/0BybdY5w-PsmIUnhkS0w0TXViUzg/view?usp=sharing
(i had motor max on 40 before i tried different values)

i will fully charge the battery once more now to see if the cut off still happens then

so i charged it up again to 100%. now the battery is not cutting off as early as before, but still does. it seems like it hits a certain threshold and shuts off. i made another video: https://drive.google.com/file/d/0BybdY5w-PsmIdERCUkplRnZTNWc/view?usp=sharing

you can see that i’m accelerating slowly, all of a sudden it cuts off, the battery counts down to 0%.
But right as i hit the brake it was booting again (normally i have to power off / on)

@Howser So it’s cutting off now at 100% full even with the old settings, yet it didn’t before making the changes?