Enertion Space Cell overcharged?

So I’ve been using the space cell 10s3p for a couple of days now, and I just got it off the charger. It says it’s at 100% but it won’t turn the motor. I tried to connect it to my computer to use the BLDC tool, but it won’t show up. I connected my setup to a lipo battery I had lying around and it works fine. Not sure what’ wrong with the battery.

Did you blow your fuse?

There is still power to the vesc because the lights are on. I tried to replace it anyways and no difference.

Did you run a motor detection?

With the lipo battery yes. I can’t with the space cell because it won’t connect

When the vesc power, what are the les status you see?

can you maybe post vesc data? In particular the voltage? Or if you have a voltmeter that works too.

I second the volt meter - what’s the Space cell output measuring at? At the XT90 plug w/ meter?

I’m going to buy a voltmeter today and i’ll check. I left the battery disconnected and on all last night. It still read 100% this morning, but it worked. Hopefully this doesn’t happen again.

1 Like

Good news, but i wouldn’t trust the battery display… Especially if it reads 100% after being on all night.

Measure it w/ a meter and let us know. Hopefully you just need to adjust/replace the battery display if that’s not working right.


I think you might have some funky setting in your, if you don’t mind posting them just to be sure there is no problem with them :wink: