Starting Tips | Ask Questions | Introductions | Categories

Enertion VESC stopped working after first motor detection

Hi, I had my VESC hooked up to a space cell, and VESC to my enertion r-spec motor. BLDC firmware was at 2.8, up to date, so I had no problems connecting the VESC to the BLDC tool. I was following vedder’s step by step guide to getting motor detection.

Read configuration, set sensor mode to sensorless, commutation mode to integrate, motor was not carrying a load. Ran start detection, and the motor got going! It started up super fast VEEEEEE, slowed down for awhile, then suddenly jolted up again VSH and the next thing I know, the VESC disconnected from the BLDC tool, and the blue and green LEDs that usually show the VESC is powered up no longer light up.

I’m not particularly upset about things not working, just kinda bummed cause the motor started spinning and I got so excited thinking I almost had everything in place!

What went wrong, and how can I prevent it from happening again? Could it perhaps happen to be a bad VESC? I’ve already ordered new ones, one from enertion and one from ollin boards as I’m really excited just to get going and riding.

Here are pictures of the VESC now, I don’t have a trained eye to look for defects. Any help would be greatly appreciated, love this community.

Could the part in the red box be what’s up?

I’ll be more than happy to add more photos if you need a closer look at a specific part!

Those bridges in the red box are ok, they’re bridged on the pcb too.
Did you type ‘faults’ in the terminal window of BLDC tool to find out if there had been any errors ?
Have you tried an alternate power supply to the VESC ?

1 Like

I noticed a few possible bridges, hard to tell from a photo. Also check for bridging on the usb port.

same thing happened to both of mine, good luck getting them replaced.


1 Like

Thanks for the great advice @trbt555 ! It hit me the other day that my SPACE cell has a fuse so if anything happens, that should blow right? So I changed, the fuse, and my VESC lights up again! I tried running motor detection again, and the same crap(motor starts and stops abruptly, VESC no longer lights up) happens. I’m on my last fuse now, and the VESC has lit up again. There must be something I’m doing wrong that’s causing it to short everytime??

I think it’s a 30A fuse so there is definitely something wrong, you shouldn’t be blowing it.

Unfortunately Enertion does not test their VESC under load before shipping it to customers so it’s basically a hundred dollar gamble.
I speak from personal experience and the forum is littered with similar stories.
It’s a pity, the VESC is getting a bad name this way.
But let’s not jump to conclusions just yet.

Where you trying to RUN the motor or where you trying to DETECT it ?
(Enertion’s VESC’s should already have the correct parameters for your R-SPEC so you wouldn’t need to detect it)

Before you do anything else, set the Batt max current limit in BLDC to a value way below the fuse rating, say 10A.
Do the same with the Absolute Max value. That way you hopefully won’t lose power to the VESC.

Now try to run the motor from the BLDC tool (up/down arrow keys) and if the VESC cops out, type “faults” in the terminal to find the faults since last boot, report back.

Be careful setting the battery max too low. Some VESC’s have burned up the drv8302 from doing this. I am not sure exactly what has happened with them but I do know they were working perfectly before setting the battery max to a lower setting while still outputting 80 amps.

Check out the recommended space cell settings(in the vesc faq section), and change your settings to match those before doing another motor detection. Also check for faults as @trbt555 said.

Okay, great news! I tried my best to follow all of your instructions.

@trbt555 Were you trying to RUN the motor or where you trying to DETECT it ?

I was trying to detect it. I AM using the enertion r-spec motors, so I guess I’ll skip on motor detection and not take the risk with blowing my last fuse!

This time, with my 3rd unblown fuse, I followed @cmatson’s advice to use the recommended space cell settings. While typing in the changes to the numbers, I hit an arrow key and the motor spun up! I then found that using the arrow keys to control the motors worked fine, so that’s great!

However, when I plugged in my nyko receiver using the JST connector, it doesn’t work properly. What I did exactly:

  1. connect VESC to bldc tool
  2. read configuration, change settings, read configuration then write configuration
  3. motor runs with arrow keys
  4. plugged jst connected wiiceiver to appropriate ports, wiiceiver lights up and nyko controller connects to receiver, can tell from solid red light
  5. changed app configuration from ‘no app’ to nunchuk, write configuration, reboot connection between vesc and bldc tool
  6. moving the analog stick on the nyko controller does not work or affect the motor. Using the arrow keys also does not move the motor

Unplugging the receiver makes everything work again with the arrow keys. Any ideas on what’s up? Also, should I change over to a different thread for this? It could still be vesc related though.

Also, I ran ‘faults’ in the terminal, and this is what it said:

The following faults were registered since start:

Current : 14.7
Current filtered : 26.6
Voltage : 37.58
Duty : -0.00
RPM : -1.2
Tacho : -236
Cycles running : 0
TIM duty : -3
TIM val samp : 1618
TIM current samp : 3718
TIM top : 4200
Comm step : 5
Temperature : 251.99

Thanks a lot you guys! I’m moving forward one step at a time thanks to your help

It might be not the solution for your problems (the temp fault is irritating), but the second “read configuration” in your step 2 is definitely bad idea. It switches values back to default and afterwards you’re writing only the default and not your changed settings. So just omit the second “read config” and the values should be written correctly.

As @elkick pointed out, you may be re-writing the default settings.


  • connect VESC to BLDC
  • App Configuration Tab
  • General tab: App to use : nunchuck
  • Nunchuck tab: control mode current
  • Reboot VESC
  • Reconnect VESC to BLDC
  • Tick "Display"in the App configuration/Nunchuck tab
  • Thumb the joystick and verify the signal is being received, under the “Display” tickbox you should see the bar move in sync with the joystick.

If that doesn’t work, re-check your receiver-to-VESC wiring :

The temperature fault (251 ° ???) is disconcerting, this may be interfering with the VESC operating correctly. Check if this fault is coming back consistently.

I double checked all of the controller wiring, and the wiiceiver lights up when connected, and blinks when z and c buttons are pressed, but with display checkbox checked I don’t see the bar moving with movement of the analog stick.

The temperature fault consistently turns up after awhile, although usually it hovers around 95-100, that one time it was a 250 was an anomaly.

I’m getting this now, it means there’s a spoilt driver motor chip or something right?

The following faults were registered since start:

Fault : FAULT_CODE_DRV8302
Current : 5.6
Current filtered : -0.3
Voltage : 37.58
Duty : 0.00
RPM : 6.4
Tacho : 17
Cycles running : 3
TIM duty : 263
TIM val samp : 10
TIM current samp : 26384
TIM top : 52747
Comm step : 6
Temperature : 95.13

Current : 38.0
Current filtered : 36.3
Voltage : 37.56
Duty : 0.00
RPM : 2.9
Tacho : 21
Cycles running : 0
TIM duty : 3
TIM val samp : 10
TIM current samp : 2110
TIM top : 4200
Comm step : 4
Temperature : 100.62

So I guess it wouldn’t be wrong to say that I had bad luck with the VESC I received?

I’ve been following this for a little while and was curious if you had any new developments?

I ordered a new VESC from enertion since everything seemed to be so wonky, but still very doubtful about whether or not it’s my fault (bad soldering, wrong wiring etc).

It arrived a few weeks ago, and I’ve just got it to work today! It worked straight out of the box, awesome stuff, and nice to know that I didn’t do anything wrong.

Going to unscrew everything from the motor mount and re-screw it on with loctite this time! And then maybe buy a new penny board to put everything on since I have nice memories with the current one lol.