Enertion VESC-X failing

I just received my Enertion VESC. However, during setup, the VESC gave a ‘fault’ warning by a red flickering LED, after which a part of the VESC blew up by giving just a little throttle. I have no idea how the error/failure occurred whatsoever though. I wonder whether anyone recognizes a similar problem with this VESC and/or knows how it could have occurred. I use a 10s Space Cell Pro4 battery and a 6355 260KV motor.

The photo underneath shows the damage/blown up part of the VESC. It’s the part connected with the middle phase wire.

looks like 1 fet completely burned, what were your latest vesc configs? post screenshots of motor configuration, advanced, and bldc/foc tabs depending on which mode you were

Yes it did indeed. I used FOC mode and read configuration at start for everything and didn’t just change random variables. Here are my latest VESC configurations.

Motor tab:

FOC tab:

Advanced tab:

did you do motor detection on FOC before trying to run the motor (detect and calculate parameters)?

Yes, I ran full motor detection on FOC before I even let the motor spin by myself once. Pretty sure I did that 100% like it should.

parameters seem alright to me… maybe a bad mosfet (that component that burned)?

Ok great, then I know it wasn’t me doing completely wrong things. I think the chance it was a bad part is the biggest too. Already luckily got a private message response from @carl.1 they want to send me a new PCB for replacement.

Not sure if that’s the reason but you typically want to stay below 200kv with a 10S, and your ERPM limit is way too high, it should be 60K/-60K, you might have busted your VESC because you reached that limit…


Didn’t spin the motor during setup at around so fast, so probably couldn’t have bust it due to exceeding the ERPM limit. Will I be safe when limiting the max/min ERPM to 60K/-60K, without having to buy a lower Kv motor? And would this result in a major decrease in top speed or not so much?

I think it should be fine, I guess you’ll lose a bit of torque compared to a 190kv motor.

Ok, that will have to do. I live in quite a flat area, so wouldn’t need that much torque.

well spotted

Do you have any idea on how to accelerate faster? My board can push me from a full stop but it moves extremely slowly.

For faster accelerating you need more torque as far as I know. You can get more torques by using a lower KV rating motor, smaller diameter wheels, a higher ratio drivetrain (less teeth on the motor puley/more teeth on the wheel puley).

I had a hobbyking esc before my vesc and it accelerated extremely fast but this is so slow, I think it’s my programming or something

I own a maytech vesc and took it for my first ride today, I’m running with a sk3 245kv motor and my battery is a 5000mah 3s 20-30c battery (I run two in series). I have my max motor amps on 60 aswell as the battery and my start up boost is on 0.090 yet I’m still have trouble accelerating, it’s very slow and I’d like a bit more kick. I weigh around 75kg and have not had problems like this on my previeous vesc, so if anyone knows how to fix my issue that would be greatly appreciated! Also my wheel pulley is 36 and my motor 16, my wheels are 90mm

I had a similar experience switching to a VESC from an FVT. The RC controllers we commonly use don’t limit amps (I was seeing spikes near 150 amps from the little FVT) and BLDC motor torque is directly related to amps, so of course, the cheapie/simple RC controllers will feel more powerful as they are outputting 2 to 3 times the torque depending on your VESC settings.

If you stick to 245kv motors, you’ll need to run a dual set-up w/ VESCs to have a similar acceleration feeling to your single hobbyking ESC or you can maximize your VESC by running 12s on a 170kv motor (60k eRPM limit) and gear it appropriately- though it will still not be as punchy as your single, in my experience anyway.

This is the only weakness the VESC has when compared to RC esc’s though; all the other customization options, not to mention reliable/quiet brakes, make it my favorite controller by far. Just have to know it’s limits.


It makes sense but I’ve seen you tubers get loads of torque from their single motor and a vesc, what’s the max amp limit I can set it to? I just need to find that sweet spot I guess, but I find it odd that even thought the motor max amp is set to 60 the max it has pulled is only around 52a

The max amp limit will automatically be set when using ‘read configuration’ in the BLDC tool. Putting the given read value higher will most likely damage your electronics as far as I know.

1 Like

Thanks, my motor has never gone as high as pulling 60 amps, but my vesc isn’t turning on not showing any lights nothing, it was working fine next day I turn it on run the motor for a bout 5 seconds and then it just stopped, no dodgy connections I was only pulling about 40amps and the vesc was around 30 c, now it doesn’t do anything :frowning: