Fail-safe on Mini remote not working?

I feel like I set everything up correctly in the bldcc tool. I set the pulsewidth correctly to where neutral is at 50% and max/min are base on reading in the tool. I bound the remote and then unplugged the loop key with the remote on, in neutral.

However, I’m still having an issue with when it cuts out, the brake is applied for a half second which is terrifying when it happens going fast through an intersection. It always happens at intersections here in NYC (primarily in midtown), which I assume is from all the cameras and sensors interfering. Anyway, is there any way to avoid having the brakes applied? I’d prefer for it to just not respond. It never last more than a split second. ANy advise is appreciated.

Never had a drop out with the mini remote (though I ride through the hills of s in residential neighborhoods, not the downtown), so I can’t say. Sounds terrifying though, cause I love traveling above 30 mph at all times possible, and I use this remote daily.

By removing the loop key, you are not simulating a failsafe, but a loss of power. Try turning off the remote while running and let us know what happens. If it acts correctly, it sounds like maybe you’re having power issues. Maybe overcharging?

1 Like

No issue when I turn remote off while riding.

When you says overcharging, are you referring to regenerative braking when on full charge? If so, I don’t think that’s it because this happens mainly on acceleration or just gliding, not when braking, no matter how charged my battery is. I’ve had the same issue with my metroboard previously which also uses the same remote.

What ESC are you using? Are all your electrical connections solid?

FocBox, 12s2p 30Q battery, single 190kv 6374 motor

All of my connections seem solid, so I’m not sure what’s going on. I assumed it was a loss of remote connection, but maybe not?

Try fail safe and setting the knob to about 2 oclock.

What loop key are you taking about? Do you mean the binding plug in channel 4 of the receiver ?

Correct. Meant bind plug, not loop key

It’s probably not a failsafe issue then. Could be a wrong setting on Vesc

1 Like

Do it exactly like in this video. It is important to remove the bind cable while the remote and board is still switched on. By this the receiver knows where your idle position is. You can test afterwards by switching off the remote and check the pulsewith signal in bldc-tool. It should still stay at 50%.

But that only adjusts your failsafe signal so that the board doesn’t brake when it losses the signal. Afterwards you need to find out why you loose connection. Maybe you have a carbon fibre enclosure or your receivers cable is broken or the remotes potentiometer gives wrong signals when you squeeze and bend the remote a little.


I suspect that what you are experiencing may not be brakes at all but rather a sudden loss of torque during acceleration which can feel like brakes and can send you over the handle bars if you are not ready for it. This could easily be caused by your battery’s voltage sagging down to the cut off set in the bldc tool. I’m curious what your voltage settings are.

Another possible cause could be that you have your ERPM limit set low and you have a check in the box by “Limit ERPM with Negative Torque” (This box is checked by default) Your 12s and 190kv motor has a possible erpm of 67032 when the battery is fully charged. If your erpm is set below 60k you might be triggering the negative torque. Especially if your running very low gearing i.e. Large wheels and wheel pulleys with small motor pulleys

I may be right or I may be wrong, I’m just throwing some ideas at you.

These are the settings I use for 10s and 190kv

@Ackmaniac, thank you man very much for this post. This is probably a very basic knowledge in between crowd who uses Mini remote, but for me it was very unintuitive that removing binding key when remote is still on matters :confused: