Fault_code_drv help

Can someone please help me understand these fault codes? They shut off my flipsky dual 4.2 upon initial throttle/end of braking. If I accelerate slow everything is fine. Braking is fine until it is time to come to the last little bit of a complete stop. I have to let off and re apply brake slowly to keep from rolling forward. Any help appreciated. I have tried my best to mess with all possible configuration settings.

1 2


Thanks! Yes 10s as well here but lipo. I will try the lower motor current you have suggested. The feel of 60 motor is a lot of fun, but not worth the cutouts. Will try and post back.

1 Like

Try change abs max to 140. If problem persists its a hardware problem.

Seems like it would send a drv_overcurrent if this was the issue. None the less I will def try and report back. I think it’s just too much for a 4 series vesc. That or I need more than 5000mah lipos.

well, the fault reports 233A of current so it feels like a spiking issue. I have an open dialog with the manufacturer about this atm with vedder as support and the abs max value was his first response

1 Like

That’s what I was curious of. Thank you for clarifying that. So what setting controls this to where it limits it before just cutting out. I basically want to draw less. The vesc will handle 300a burst total/150a/single. Would this be a combination of batt max/motor max?

Well if abs max is reached or passed the fault will trigger. So if you want 300A then 150A on abs max is needed. Generally in electronics you want 25% headroom, never operate near limit. I’m unsure what peak currents the VESC is practically capable of but it sounds like you’re close to the limits.

Batt max should be set to what your batteries can tolerate, same goes for motor. (max. allowed contineus thru VESC still applies tho) Batt current is not equal with motor current. (read about duty cycling)

1 Like

50A con. 240A burst. So seems like you’re in the scope after all

1 Like

I’m def under the threshold and have a little room to spare. I just wish I could limit something else to not draw this many amps or self limit when it gets near. Why would one fault at 233a and the other at 174a? I have looked at duty cycle but man that is a thinker. So I guess I have to lower motor max to not draw as much? How do you tell this thing hey at higher amp draws(low speed take off) to self limit or slowly increase. Are we talking throttle curves now?

Your posts have given me the insight I have been looking for even though I have been reading night /day on other posts they are still somewhat confusing, but now I can relate to my situation so THANK YOU!

The behaviour you are seeing in your fault is something that (probably) shouldn’t be there. Somehow the current sensing takes of like a rocket and it could have to do with cheap components or errors on the powerstage layout on the PCB. Its abit early to tell. From what I understand users have had a more stable experience below 40A con. so try that for now I guess.

If you apply full throttle from standstil, even uphill. Reaching anything above 60A is relativly hard to do. (not saying its impossible), you could set a less agressive throttle curve but if this is a hardware fault, its hard to tell if it will help at all.

Yeah probably hardware. Even with abs max at 130amp I somehow hit 328. Probably almost blew up the esc. I just don’t get it. It’s like the settings aren’t 100% set in stone. I saw another forum a guy set his motor max to 40 but he still hit a peak of 56. 3

Is there a reason it is negative? This is during throttle not braking.

You did a motor detection right?

For sure. I’ve also tried bldc but have same results. I’m just going to run waaay lower values than I expected to be able to. This brand must be the reason it was cheaper than others.

Should I do it with no resistance like take wheels off and everything?

did you do this all with your wheels and belts?

I did. Possibly causing issues? I can take everything off and report back. Maybe we found a huge solution.

Yes always do the set up not under load or with belts on

I doubt there actually is 380A there even tho it says there is. Thats just ridic. Something is causing anomelies. Power Electronic can behave really wierd if something is done wrong. Its not just connect stuff and hope it works. Alot of things to consider. Theres a reason most 4.2 hardware look a like. Its cause it works. And redesigning is a risk