Starting Tips | Ask Questions | Introductions | Categories

Fault Code: HIGH_OFFSET_CURRENT_SENSOR_2 after firmware update - SOLVED

So, maybe not too surprising but I tried these cheap VESC on ebay, which are nearly half price:

And after flashing the firmware successfully the red light is flashing, the terminal fault reports:

FAULT_CODE_HIGH_OFFSET_CURRENT_SENSOR_2

My guess it is something that is out of spec on the hardware that maybe old firmwares were ok with? That is why they are on sale?

Anyways, if someone who is experienced with VESC can let me know any more test to run, or some options I might have. I tried this on both VESC I order and they both have the same problem after firmware update.

If there are on-board voltages to test or components I might be able to replace to bring it back into spec, that would be helpful. If anyone can point me in the right direction of the part of the circuit this error would involve.

You get what you pay for!

It appears this detection was added in version 3.55 so, yeah I guess it is a new feature!

Hella noob

Running motor detection clears the faults I will go into hiding now.

ostrich%20hiding%20its%20head%20under%20sand%20to%20protect%20it%20from%20strong%20wind

4 Likes

Hey bro,

I get the same error running on BLDC mode in 3.55 using my dual 4.2 from Flipsky…

It triggers the same error every time I reboot the board so I will have to run detection all over again every time I turn on the board :frowning_face:

Same on 3.55 and HW 410 from Torqueboard.

Just updated from 3.54 to 3.55 not both my vescs blink and the Motor detection fails.

Can’t even fnish the Motor setup.

Dang it…are you able to save it by downgrading the vesc fw? Or is it not possible?

I’m currently trying to research it.

it is possible, but for impossible to find the older Firmware.

EDIT : Update? I fixed it by using the VESC tool 1.08 which only supports up to 3.54.

Connected and flashed it. No the blinking is gone. Lets see if i’m able to program the VESC so i finally can drive.

1 Like

Hope it’s ok after downgrading the fw, mine runs only in foc mode…I’m keeping it in foc mode for now cos I don’t wanna mess it up further…

Yep, so far so good. I was able to do the setup and it works. I’ll keep it at 3.54 until a fix is present

2 Likes

Luckily my problem went away after motor detection and stayed away even through powerup with the recent software.

Great to hear that mate :slight_smile:

Were you in FOC or BLDC mode yea?

FOC, just using the wizard FOC is the default configuration.

Alrighty, then I am in the same situation, it works fine in FOC but not BLDC :sweat_smile:

Oh weird, I didn’t try BLDC. That is weird cuz FOC should be more difficult to do than BLDC.

And theoretically still works because I ran the motors up to speed that should be above FOC.

My guess is they have a different value resistor somewhere on the sense circuit and the value is just slightly off what it is expecting, but hasn’t been an issue up until this update.

Probably… Because I wasn’t having any issues running BLDC on a few updates earlier too… until the recent FW 3.55 version :-1:

Thanks a lot man! I just repaired a FOCBOX with a broken MOSFET and DRV. Flashed 3.55 and got stuck with this fault code. Never seen it before and had no idea how to fault trace. reverted to an older sw and now wheels are spinning. :sunglasses:

Glad to hear that!

Where did you get the 1.08 from? My buddy is setting up a brand new board and is having the same issue.