Faulty v2.17-2.18 bldc-tool win/osx!

Anyone updating to the win/osx version 2.17-2.18 bldc-tool should know that it is causing VESC’s to fail. @jacobbloy please take this faulty version down.

We will be asking those that have already toasted their VESC to carry the material expense and shipping for this repair. Don’t worry, it wont be much, probably just a drv chip. Hopefully it isn’t frying the pcb’s. We will have a better idea of the cost once the first round of repairs comes in.

The linux version 2.18 operates fine. win/osx users should stay on 2.16 until further notice.


thanks m8 4200

Wow just got a used 4.7 VESC and tried to update it to 2.18 using that version and it kept saying that it was 2.15 even after updating firmware. Downgraded tool to 2.15 (version that was installed) and it worked fine, glad I didn’t keep trying to get it to work…

@chaka I updated it a week ago mate!

The only problem was with FIC giving the wrong kp and Ki results.

Guys I have no idea what version is my boards VESC is. I just started riding today as I bought a used board which was already setup for me. Do I just plug it up to the PC with the program? I have no complaints so far so why should I upgrade the FW and risk damaging it? Thanks guys.

We’ll see what is going on. We had something like this happen awhile back with an update and all that was needed was a reflash of the firmware. Until then I suggest staying at 2.16 on win/osx and 2.18 linux.

Also the few ppl that have contacted today about this have all said they tried to update there firmware and then started to have problems,
I asked all of them what version vesc they are using and all of them said they didn’t know.

Sadly this is a problem we don’t know if they have used a 4.7 firmware on a 4.12 vesc.

I have know tested Windows and OS X and have done over 20 firmware updates on both going from 2.16 and 2.17 to 2.18 and then done a ride up and down the hall way and no problems,
I have a bad detection on 1 vesc in FOC but this vesc flashed red 4 times like it does when you don’t have an updated c18.

I will keep testing tho.

If they don’t know which HW version they have, how can they select the right firmware to install? Is it possible that the problem is not with the Windows port but that folks are attempting to update VESC without fully understanding the process first?

I empathize with those who end up with a dead VESC!

@c4Lvin this thread is a great way to get started with your VESC. There’s some learning to do before you start upgrading the firmware. Short answer to your question is that you don’t have to upgrade if you are already happy with performance.

1 Like

I empathise with them 2 and after @chaka gets them back and checks what the problem is, if it’s my doing I’ll try and chuck some money the part replacement fund. But I use the ported software at least for an hour a day and I’m not having these problems.

1 Like

Awesome that you would offer something like that! We will probably not charge anyone for this, I think the worst of it is over so we can take the hit. Worst case I can send these guys some rebuilds I have set aside for myself.

The good news is on every case they have not been able to revert back to version 2.16 so I think something is going on during the initial update to 2.18 on wind/osx I am betting it will be resolved with a reflash on an st-link.

Is this still an issue or has the BLDC tool been fixed?

Only an issue for those that downloaded during that short period of time.

This still seems to be an issue, however.

Thanks @jinra. I can confirm that this is still an issue with the latest Windows version of the BLDC tool downloaded from @jacobbloy’s site

I would say this is an issue with all code, as I have build this direct from Benjamin’s branch. And building it in a new OS does not change little code sections like this.

Where can you even find 2.16??? It isn’t under the “older versions” on Jacob’s website which is an obvious problem. Is their anywhere else to download the the tool?

2.18 has worked fine for me, the only thing weird is the bug I mentioned above.

Good to know that 2.18 is still safe except for the minor bug.

@michaelcpg @chaka From looking into it and talking to Vedder today this problem originates in the firmware not BLDC tool, it has been fixed on GitHub but not with the previous firmware files that are made when building BLDC tool, so those using Linux will not have the problems.

I will try and find time to rebuild the firmware and reupload them.