First Build: need help (maybe just a switch idk)

Hey guys, apologies because I am very new to this. This is my first build, and it just seemed to stop working after I moved back home today from a semester at college. I think the problem is that the on/off switch is broken. I try to press it and nothing happens. I have spammed the button repeatedly and gotten it to come on a couple times. When this happens the board works just fine, I can ride it and there is no reduction in speed or anything. I have already checked the voltage on both of the batteries and they are fine so i don’t think that is the problem. I cant consistently get it to power on with the button though. Its like if i want it to power on I need to sit there for minutes pressing it repeatedly hoping that it comes on. The same problem is happening when it is on and I want to turn it off. I am lost on what I should do to fix this problem. If it is just as simple as replacing the on/off switch please let me know where I can find one. I have attached a picture of the wiring (sorry I know its a mess) and links to the parts I am using for the build. Any help would be greatly appreciated.


Main board:




1 Like

Could just be that the switch is dead, have you tried looking for a replacement?

this just happened last night / today, the only replacement switches i could find would take 14-55 days to ship, coming from china.

Yeah that sounds about right. Where do you live? Country wise

The US. I live in New Orleans but go to school in arkansas.

Have you tried looking for similar switches on Mouser, Jameco, Digikey, etc?

1 Like

I just spent a little while looking around on those sites, I cant seem to find any switch that has the 4 pin jst connector that mine has.

Do you have any suggestions?

1 Like

Touch the orange wires together first to verify if it is indeed the switch that’s broken.

If touching the orange wires together turns it on, proceed to buy a switch.

Make note of whether the ESC stays on after you stop touching them together. (If so, you need a momentary switch)

1 Like

This is a good idea, I’ve never had to do tests like that before because I run Antispark Loopkeys on my builds so I’ve never had to deal with a momentary switch.