First time VESC user, trying to figure it out

Hey guys

I’ve got a VESC as a gift (older version) and trying to figure it out, so far no success. Hope for some insight from you:

Here are the symptoms: It is connected to battery, motor and is detected with VESC tool. Then it says my firmware needs update. Doing the update, all seem normal, except the red line that appears through the end (see pic). Next time I connect it the story repeats itself, prompts for firmware update and all repeats itself.

Any ideas how to tackle this? vesc vesc%20error

Thanks, Dani

Did you check your hardware version is the correct match for the firmware you are trying to flash? there should be a number on the board somewhere.

Once you make sure you’re flashing the right firmware, do a full power off and reboot of the VESC.

1 Like

Mine says vesc 4.7 on the board. Tried several options with the vesc tool, still same result.

Thank you, Dani

If it’s hw 4.7 I think you need to flash this file

If you did flash an other fw than your vesc now probably blocked and you need a st v2 link to upload the hexfile and firmware to make it work again

Andy, thank you. I will try this.

Can you point me to the instructions as to what to do once I have this programmer at hand?

Thanks, Dani

I never made it by my own, but look through this threat

@Eboosted wrote down everything there step by step

Cool, will try it this week Thanks again!

1 Like