Flipsky Bluetooth help

Hi everyone,

I need some help with using the flipsky Bluetooth module. I have it plugged into the Flipsky 4.2 dual ESC.

It refuses to pair with my phone and keeps giving me an error when I try.

I am unable to get it to work with the ackmaniac app. It just won’t connect. it says it has connected but nothing happens on the app.

Due to this I tried using the standard VESC Tool and loaded the firmware to the FSESC and I can connect to the VESC Tool Android Mobile app through Bluetooth (still unable to pair the Bluetooth). But I am unable to connect to the Bluetooth from the windows VESC Tool as windows says it has paired but the module does not appear when trying to connect through the app.

Am i doing something wrong or is the Bluetooth module from flipsky extremely limited with what it can connect to?

I really want to use the Ackmaniac app as I want to use the features of being able to switch between different configs for when newbies are trying out the board as I have friends with a terrible sense of balance who want to try it out. It seems the VESC Tool for mobile doesn’t have those features yet.

Appreciate anyones help with what they think I should do.

Cheers, Patrick

1 Like

I’m facing the same problems, as far as I know it won’t connect to the ackmaniac app, you need a different Bluetooth module for that. As far as using the VESC mobile app, you need to look at the flipsky website for the module and check that the wiring is correct. Mine came with the pins in the wrong place.

I am still having trouble properly using the Bluetooth module to connect in canbus mode to write to both escs at the same time.

It will not work on Android 8. You’ll have to flash the firmware or use an older phone

1 Like

I was using an HM10 and ackmaniac’s app, had to downgrade the vesc firmware to get it to work, apparently VESC 3.40 fw causes problems

I had everything working great on 2 x fsesc 4.12. Then last month I have stopped getting any telemetry from either of them.

When i connect it can see my motor battery limits but nothing else.

@Grozniy I don’t think the android version makes a difference with the flipsky bluetooth modules. I am getting the exact same experience with Android 9 on a Pixel and Android 6 on a Nexus 5.

@Jmding how do you downgrade? When in the ackmaniac app it only shows the latest firmware to load onto the Vesc? Do I need to download an older version of the ackmaniac app? I am a newb so any help would be really awesome.

@chrischo1996 The wiring seems fine as I can get the VESC Tool Mobile to work but nothing else. I have some HM-10 clones around. And I have an arduino lying around so I may try the firmware rewrite on the HM-10 and give that a go.

Thanks for all the suggestions everyone.

flipsky has responded and they have advised their Bluetooth module will only work with the VESC Tool.

Did you make an update on your phone but didn’t updated your app?

Not too sure what you mean.

Ackmaniac app is version 1.114. Vesc tool is version 0.95

I wouldn’t know how to update the vesc tool and there doesn’t appear to be any updates available for the ackmaniac app so I think everything is up to date.

Someone suggested downgrading the vesc tool to version 0.91 which worked for them but I don’t know how to downgrade (or upgrade lol).

Are you using the flipsky bluetooth module or are you using a HM-10 module?

I’m using a hm-10.

I’ve managed to sort it by flashing the vesc with ackmaniac vesc tool. I was running vedders so I’m assuming an upgrade to 0.95 has made the (ackmaniac) app incompatible.

From what I understand you can’t use the ackmaniac app without having the ackmaniac software on your VESC.

As far as I know most apps support HM-10 and not nrf51 - which is what your Flipsky module is based on. I think the Xmatic app by @twan supports the nrf51.

But that is iOS only. So useless to me.

Just swapped in a hm-10 clone I had lying around and it works perfectly.

Yes it appears you now need the ackmaniac software on the vesc.

Although, up until a few weeks ago I was using the app without ackmaniacs extended tool.

I thought my modules where faulty because they all just stopped reading telemetry all of a sudden.

Had to install ackmaniac tool to all scooter vescs to fix the problem.

Looks like 0.95 is no longer compatible.

I had no idea. I had just assumed you needed the ack software to use the phone app. I didn’t realise there was a change as I din’t have a bluetooth module in a board until now.

I believe ackmaniac’s app works with Vedder’s FW, but vs 3.40 (the current version) is incompatible, while 3.39 works. I wasn’t able to find 3.39, so ended up flashing ackmaniac’s FW.

1 Like