Flipsky vx2 battery wrong indication for skateboard

Hello everyone

Recently I have upgraded my skate with flipsky vesc and vx2 controller and it works wonderfully, but I noticed strange thing about battery charge indication on my remote. It shows 0% despite having about 30% of battery, according to my indicator on the board and multimeter readings. My battery is 10s3p 36v lion, so I installed those parameters in my vesc configuration, including cutoffs, my vx2 set to 10s, battery indicator on board itself shows percentage and voltage as it should for 10s setup. I tried to Google anything on that topic but I guess no one made a post about it. I added pics to show the setup, maybe I’m missing something

Btw, board rides perfectly, just vx2 shows I don’t have any juice left, when actually I do

1 Like

Did you solder the battery + wire lead that is on the vx2 receiver to the battery wire positive side (red wire)?

I would also recommend using voltage instead of percentage to see how long you have before its discharged. Better that way tbh.

1 Like

I haven’t solder it, thank you, I’ll try it out, didn’t know it should be soldered (connected it to vesc and thought it’s enough)

My indicator has two modes, as shown on pics, usually I use voltage option

Yeah, you’re supposed to solder it. Its on the receiver as B+ and that goes to battery.

That will solve your trouble.

Should I reset anything afterwards in terms of software? I added a jumper to test, nothing changed…I had bat+ on receiver so I connected it to positive of vesc. Soldering is solid, everything checks on voltage meter

Not really. Just turn on the remote again and it should now show the battery percentage if you soldered it on the positive wire of the battery.

Nah, I guess I messed up elsewhere…it still doesn’t show charge on remote

I tried to solder it to various points (directly to battery, to xt60 connector on vesc), Turned on and off everything several times, setup battery cells again on remote, same thing.

I found some diagrams, tried different “app to use” parameters in vesc tool according to them, no result whatsoever

Thank you anyway image

1 Like

Oh well. At least it works.

Yeah, maybe someone reads this post and they will be able to solve it that way

Or even suggest another solution

1 Like

Can you just solder the receiver wire to the battery positive without disconnecting the negative? Just switch off the board completely and solder on? No sparky spark?