FOC Negative Power?

Anyone seen this before? If i push my throttle to about 20% the motor spins at max, but if i press it down some more the motor then sounds like it has a load on it and the graph shows negative wattage and the mosfet temps increase really fast.

Calibrate ppm/ your remote

1 Like

It is calibrated though :open_mouth:

Rerun motor detection? Any faults showing up? You’re running 2 vescs? Does this happen on both or just one?

1 Like

Wow thats weird so I switched the ppm from 1.92 to 1.93 and it fixed it, thank so much ! So weird. Any clue why it does that?

The remote itself could’ve lost calibration. I would suggest the extended firmware by @Ackmaniac, the wizard there might give you more reliable values

ahh i flashed his firmware and how the problem is back. max throttle gives me -150 watts no load… this is gonna make the motor heat up reall quick…

What remote are you using also make a screenshot of the application tab

@twan did you run wizard after you flashed firmware? And write settings

@scepterr yess i ran the wizard and got the controller all set up to get the correct range but still dont understand why the motor is getting -150 watts at max throttle. when it was set at no app and i use my keyboard and maxed it, it showed 50wats but when i changed over to my mini remote it gets fked up. ’

@Bloop im using the mini remote

I’m not personally familiar with that remote

Just don’t torture the Vesc on the bench. Via remote you tell it to use much power which it can’t use because it spins already at full speed. With the keyboard you tell it to use little amps which are enough to reach max speed.

Its like you at work. Keyboard is when your Boss told you to do something and lets you do it quietly. Via remote is like he stands beside you with a megaphone and shouts at you to work faster the entire time.