FOCBOX no longer responding. Only blue light showing (Solved)

Hi folks, I’m at a bit of a loss here.

I finished my esk8 build two weeks ago and for the most part everything has been working fine. (build thread coming at some stage :smiley: ) Today while trying to get bluetooth to work, one of my two FOCBOX’s stopped responding and is no longer recognized by the PC. When powered, the blue light comes on, the red light flashes once faintly and no green light. Its not recognized in the Device manager but in know the cable and everything else works because the other FOCBOX connects just fine.

I have spent a few hours reading but can’t seem to find any other threads with this problem

Any help would be greatly appreciated

I’ve seen this before. Not sure what caused it but it ended up in the @JohnnyMeduse bin.

1 Like

Is the Bluetooth still connected?

Also, which firmware are you using?

BT is disconnected. I first noticed the problem after removing the cable. the other focbox has been fine with the module

look like 3.38

Hummm… I think It could be a firmware Issue, you might need to reflash your vesc using a st-link.

Other ones poor smoke

I’ve had this kind of issue with my Raptor 2. Only under 50% battery though. Does battery percentage have anything to do with your issue?


Just want to know: your other FOCBOX connects to Windows without any issue? Your other FOCBOX also have 3.3xx FW? Your other one shows green light? Have you connected them via CANBUS? Have you disconnected the CANBUS once without removing it from both of the FOCBOX together?

Thats a Yes for all everything. They have both been working perfectly for 2 weeks.

Regarding the canbus. It was hot glued in place on both ends. I’ve only removed one end while trying to diagnose this problem. It’s still plugged into the one that works, is that a bad thing?

Thanks, I’ll look into that


OHHH! Man I think you just fried CAN transceiver of one of the FOCBOX. It must be the one on which CANBUS cable stay connected. @JohnnyMeduse What do you think?

I just did a firmware update to 3.102 and unplugged the can bus connector from slave while leaving it plugged into the master. Unplugged the receiver from master then upgraded firmware on master, redid motor detection. Turned it off, replugged the receiver and did the app / ppm settings. Then connected usb to slave, did the detection and slave app. Then turned everything off and reconnected the cable coming from master into slave. Started everything up again and all good. Did a test for 10 miles, all ok.

Why would a can cable connected to a focbox but not connected to the other fry the can bus? Makes no sense.

As far as I know what you don’t want is a can cable connecting two focboxes while only one is powered. A cable that is not terminated shouldn’t fry a can bus chip.

1 Like

No… if it was a blown, nothing will even light up. That sound more like a firmware issue

Neither CANBUS where removed before the problem occured. (i have had the connection drop out while riding though, even with hot glue holding them in)

There’s a chance that the buad rate for the BT was not changed to match the module, if that helps?

@JohnnyMeduse it happens with one of the customer, I am not tech Junkie, not aware of the technicalities but I think he Might blew something which have 5V.

For software, I just read the whole thread now, Sounds like it’s FW issue. He need to use ST link to flash it back to default one

sounds like canbus chip. did you have one box disconnected to power while still connected by canbus?

nah. the way i made the parallel adapter is too annoying to disconnect them.

@JohnnyMeduse @CarlCollins

I have ordered an st-link and read the walk through about it. I’ll let you know how that goes.

thanks for the help.

@CarlCollins @JohnnyMeduse.

Good news, everyone! Flashing with st-link worked.

took longer to find the firmware and crimp up some wires than fixing the brick lol

Many Thanks!


Great! Now you should mark this thread as solved :slight_smile:

1 Like