FOCBOX UNITY | Support, Setup & Troubleshooting

i got 3 of those about 2 weeks ago. I first tried to plug them in but could not find my glasses so i figured i’d try later after i found my glasses. I’m going home to check them out.

@Deodand I took a video of something with my Unity. One of the motor flashes a negative voltage constantly. At first I thought it was my motor, but today I flashed the new firmware with just the Unity connected to the battery. Not covered to the remote receiver either. Just want to know this won’t be a problem when I ride my build.

1 Like

No it’s totally fine. It’s just background noise from the sensor readings.

1 Like

Can someone direct me as to what kinda cable conversion I need to buy to convert the Meepo 5 pin hall sensor connection to the 6 pin the Unity takes? and which wire goes to which terminal please if there is an order.

Also does the 3 power wires have an order too? Much thanks in advance! IMG_20190418_184511

If the meepo uses 6-pin JST-PH 2.0mm pitch headers then you’re good to go, if not, I’d just cut/remove the header and solder on wires for the aforementioned header.

1 Like

Red and black go to 5v and ground respectively. The other 3 go to the H1-H3 ports the order doesn’t matter as it will be detected during calibration. The same goes for the motor leads, the order does not matter.


Thank you @Jinra and @Deodand Now I know what 6pin to buy and the order to solder.

I realized its not just two wires wrong. Its also reversed or the plug upside down. Strange, they should know.

I think this is the right order. edit: yes now the adapters do work.


1 Like

If I remember on certain type of vesc 6 derivative the sensor port is reverse. I think the “escape” is one of those.

1 Like

Oh then that would make sense but they should not sell them as “Hall Sensor Adapter for VESC”.

Just get 6-pin (or 3+3) connectors in a local shop, no soldering is required. I’ve also upgraded Meepo NLS with Unity, I guess it’s NLS² now :slight_smile:

@Deodand it was asked earlier in the this by @lemntl but I can’t see where it has been answered

Does the Unity work with the AS5047 encoders ?

From what I can tell on V4 hardware you had to remove some input filters or change some components where V6 hardware the filtering was possibly done software side so worked without mod.

Being that the Unity is based on V4 hardware I’m guessing it won’t work out of the box or have you been able to do some kind of magic trickery to have it work ?

1 Like

Does this mean that the temperature sensor on one of the motors is not working?


Yeah it’s not reading.

1 Like

Thanks. Time to open the enclosure again :roll_eyes:

Any word on iOS/iPhone app for the go box unity? I know “it’s coming” but where can I watch and wait to get it ASAP? Having to unscrew my enclosure just to tweak things is $&@#. Is there a place I can watch for updates? :slight_smile:

@peteprez Send your bribes to @sofu.

1 billion dollars and I’ll send you the current progress (which is not working yet :stuck_out_tongue:)


If you need any help, let me know. I’m an iOS Developer :man_shrugging:t2:


Is there a cheap android smartwatch that can run the Unity app?