FOCBOX UNITY | Support, Setup & Troubleshooting

Any word on iOS/iPhone app for the go box unity? I know “it’s coming” but where can I watch and wait to get it ASAP? Having to unscrew my enclosure just to tweak things is $&@#. Is there a place I can watch for updates? :slight_smile:

@peteprez Send your bribes to @sofu.

1 billion dollars and I’ll send you the current progress (which is not working yet :stuck_out_tongue:)


If you need any help, let me know. I’m an iOS Developer :man_shrugging:t2:


Is there a cheap android smartwatch that can run the Unity app?


I know im late to this thread but do i need to have the power switch pluged into the unity. Then plug in my battery.

1 Like

Hey all, Im having an issue. On of my. Motors seems to be kind of cogging but its dofferent than “normal” cogging. Also its not all the time. It happened all of a sudden. I screenshotted my config. I will upload a video as well


did you update you fw to 23.43 (lattest)? Sensorless runs smoother with the lattest.

I did and it seemed better for a day or two and now on motor spins at speed and the pther one spins very slowly. .

Motor problems…

You seem to be missing a phase, check you connections

1 Like

I just want to shout out @barajabali, @CarlCollins, @Deodand, and the Enertion CS team for fixing my situation. Excitedly setting it up now.


Hi. I am facing an unusual situation that whenever I try to configure my Unity through the Unity Tool. Every time i am done updating the config and I turn the board off, when I turn it on it does not function. It seems that the unity forgets all motor config and starts behaving as if the motors have not been configures at all.

I am only using the tool because the Focbox UI does not have an option of controlling input dead band. That is set to 15% by default in the UI hence the need to use the tool. I have to go back to the UI to configure my motors. Has anyone faced a similar issue?

Another issue I’m having is that whenever I’m drawing telemetry from the UART from the unity, I am unable to update config. As soon as I turn off my feather remote , I am able to write the config.

Have you reflashed firmware? It sounds like somehow your eeprom (non-volatile memory) isnt getting written correctly during the config write. What pwm freq are you running?

1 Like

Yes I have the latest firmware. The frequency is 915mhz.

I had the same issue. I found that the issue was that my wires not connected all the way. A loose connection maybe the cause of stuttering.

1 Like

Ok thank you ill take it apart tonight. Did you see my motor detection screen shot? Could that be why the motor resistsnce is different as well.

Yeah I suspect that might be the issue. Mine wasn’t as pronounced as yours but I was getting stutters whenever i started from a complete stop.


How are you flashing the firmware on the unit? Using Bluetooth protocols or USB?

1 Like

Hi, I’m just starting to use FOCBOX UNITY and learn how to. My goal is to be able to use both speed and torque control in a differential platform with two BLDC hoverboard motors. I’m using (starting also) ROS to do that and I already found the vesc_drive ROS node and also managed to launch the node, but when i tried to publish the following: rostopic pub -r 20 /commands/motor/speed – std_msgs/Float64 3000 happened two things:

  1. only one wheel responded;
  2. that wheel just kept trembling (didn’t spin);

Any of you have tried to do something in this area with FOCBOX UNITY or knows what’s wrong ?

Thank you in advance!