FOCBOX Unity UI for Mac OS

I tried compiling the FOCBOX UI sources on my Mac and it seems to have worked just fine. The compiled app is here: FOCBOX_UI_1.1.app. I tested it only very briefly. I can connect to my Unity and changing basic settings worked (tried changing the controls from Forward/Brake to Forward/Reverse and back). Use at your own risk.

53

@carl.1 @Deodand Is there a reason the Mac OS version is not officially available given it’s straightforward to compile the sources for a Mac?

Are there plans to releasing the FOCBOX Tool sources? That one is clearly based on the vesc_tool, which is GPL, so you are legally obliged to release the sources.

Nice work on the Unity, BTW. So far I like everything about it a lot… except the missing Mac software. :wink:

Edit: The FOCBOX Tool sources are available (same repository as the FOCBOX UI, only different compile options). The compiled Mac OS app is here: FOCBOX_Tool_1.1.app.

7 Likes

The FOCBOX Tool is just a #define in the .pro file of the FOCBOX UI project. "BUILD_MOBILE " or some such.

Mainly it has to do with my lack of familiarity with Mac and juggling a lot of different projects we want to see successful. I didn’t have an apple computer to test these releases so didn’t feel comfortable having them as an official release. That is changing soon :smile:

4 Likes

I see. Cool. I compiled it successfully as well. Here’s the app: FOCBOX_Tool_1.1.app

I briefly tested it and it seems to work OK. Thanks!

02

21

1 Like

@Deodand A few more questions: You advertise iOS support here. Where’s the iOS app? Also, I have two Android devices and I wasn’t able to install the Android app on any of them. Are there specific requirements?

IOS app is currently under development. Can you be more specific on why you were unable to install?

It just said “unable to install app”. I didn’t dig into details, sorry. The devices used were Google Nexus 5 and Nvidia Shield tablet.

App crashes on launch. Can you try put it into a zip archive before uploading?

I can if you ask me nicely :slight_smile: but that won’t make any difference. I just tried downloading from the link and running. It worked just fine.

What system do you have? Does it give you any errors?

1 Like

I have a 2019 macbook pro.

In the os x “Error Report”:

Dyld Error Message: Library not loaded: /usr/local/opt/qt/lib/QtPrintSupport.framework/Versions/5/QtPrintSupport Referenced from: /Users/USER/Desktop/FOCBOX_Tool_1.1.app/Contents/MacOS/FOCBOX_UI_1.1 Reason: image not found

OK, it’s not statically linked.

brew install qt

should fix the problem.

2 Likes

I have the same problem how do I fix that?