Focbox Wont connect to pc (windows 10) ive tried what feels like everything

I have read every single topic on the forum that has had to do with these issues. Ive had zero luck, im helping a friend setup a brand new focbox and after being powered on (lights up blue and flashes red 3 times) and connected to my laptop, it doesn’t do anything for about 10 secs and then connects but says it cant be recognized. ive looked in my device manager and it reads,( unknown usb device (port reset failed)) every time. ive unistalled this and restarted. ive tried 8 different usb cables, taken the case off for each. tried at different voltages. tried on other pcs. even the stmicroelec virtual com port. tried redownloading both bldc tool and vesc tool. still nothing.

any insights?

It seem to connect to your PC, so it is probably a driver problem or com port problem

my pc sees it as a device is connected, but it wont show in com ports (either on device manager, bldc, or vesc tool)

any advice for a driver problem? @JohnnyMeduse

I get the same error when using a bad PC cable! When 9 use my working cable 8 have no problems but somehow i have 10 broken ones and one working one… Lol

The cable Needs to Support data Pass through. Most cables are for Power only…

Sometimes when the device is connected to the PC but not recognized it can be that the VESC does not boot correctly. The VESC gets connected after the red LED blinks 3 times and boots. Does it turn on and blink?

yes, every time

maybe ill have to go and get that 9th usb?

Does the PC make the sound when you plug the VESC in? Or give any faults like the unable to recognize device etc?

yes, both makes the connection notification sound, and then gives a warning as it was not recognized.

Try different USB ports on the PC and ideally a different VESC if you have one?

Oh and has it ever connected before?

1 Like

i dont have another vesc to try with and ive tried different usb ports on 2 different laptops. still no luck.

no, its brand new

Okay and have you ever connected a VESC to that laptop? If not it is that the drivers are missing probably, I think there is a link in the thread about setting up VESC for the first time, I will try to find it.

yes, i had 2 focboxes which i set up for my board that were fine. but they burned up due to me being uneducated about the plastic film covering the thermal tape/foam inside so im waiting on replacements.

Try reinstalling the drivers.

i have done this, but i will try again

Well if this wont help and the USB cables wont help either, it is down to the FOCBOX :confused: which is a bit harder since it does not even have the firmware/stlink connector populated. Plus you would loose warranty flashing firmware

i tried the drivers again and still nothing.


they test them before shipping? correct me if im wrong.

I think they do but accidents happen.

@CarlCollins can point you in the right direction. I don’t know the exact procedure, but if i remember well it has todo with win10.

If your lucky he’s maybe on the live chat


Yeah, try contacting enertion support on their website or here on the forum as Blasto suggested

will do, thanks guys

1 Like