Fried FOCbox ? static shock?

Hi everyone, I just went to solder my bluetooth module to my focbox as I don’t have the right connector and actually hate these connectors. SOldered 5v, GND TX and RX on BT module, tried to plug usb to vesc tool and activate UART, but I can’t connect to the FOCbox anymore … tried different USB cables, reinstalling VCP drivers, still impossible to connect … Is it possible that I fried VESC by simply soldering on it ? Like static electrical shock ? I use a Weller high end soldering station and never had such an issue solderong other chips. Would appreciate your opinion :slight_smile:

maybe you shorted the connector while soldering?

1 Like

Does any LED lights up when power is connected? Also maybe you mixed pinouts?

Maybe if you still using original case it touches wires to the case and grounds it?

1 Like

okay I found the issue … that’s crazy strange Turns out R104 ( USB data- resistor ) was reading 100M Ohms ^^ Supposed to be 22Ohms. I guess this resistor doesn’t handle heat very well :stuck_out_tongue: To anyone having issues with USB connection, check your resistor values ( R103 and R104 ) seems to be very heat sensitive !

Have a nice day guys :slight_smile:

Nice, did you soldered directly to resistors?

20180717_152956 Soldered a USB cable this way and focbox now connects to pc flawlessly! R104 still reads infinite resistance value xD An hour ago all was working right through the Mini USB port haha

wait till the upload finishes before posting :wink: